FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW Activation

I am NEW to all of this.

I downloaded LabVIEW and installed it.

I could not activate it so I cam here and read what needs to be done with the license file.

I have performed those steps multiple times and still cannot start LV wihout it wanting to activate the license.

Reading the other instance of this problem I saw that someone asked if they had another LabVIEW application installed.

I don't have that, but I do have LEGO MINDSTORMS installed.

Is it possible that this is my problem?

Thanks,

Mike Bennett

0 Kudos
Message 1 of 18
(15,486 Views)

After setting up the license folder (with the .lic extention not .txt) and downloading and installing LabVIEW I received an e-mail with several activation codes. On the Activation wizard, I selected the button for the 20 character activation code. I assumed I should use the first one for FIRST Robotic Competition to expire on Jan 15 2010, but it was not accepted. I tried the second code also labelled for FIRST Robotic Competition but that wasn't accepted either.

What step am I missing?

0 Kudos
Message 2 of 18
(2,553 Views)

Hi everyone,

Try activating over the web with the L12R86754 serial number, rather than going over e-mail. Usually the web based activation works better than going through e-mail.

JeremyB

Applications Engineer

National Instruments

Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 3 of 18
(2,553 Views)

I tried the web based activation button with the serial number. I still get the message that the specified activation code

does not match the product you are trying to activate......I believe the product is LabVIEW Development System?

0 Kudos
Message 4 of 18
(2,553 Views)

Activate the FIRST Robotics Competition version, not the Development System.

JeremyB

Applications Engineer

National Instruments

Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 5 of 18
(2,553 Views)

I found the problem. The FRC license wasn't .lic. Thanks for the help..

0 Kudos
Message 6 of 18
(2,553 Views)

okI seam to be having kind of the same issue.

I use the L12R86754 serial. but then it tells me the activation code cannot be applied to any license files. when I use the web activation it gives me a code that looks to be incorrect. when I to select a product to activate on the license manaager I do not see any product that has FRC in the name just the development system

here is the picasa album for each step http://picasaweb.google.com/Rampy1745/NI#

and yes I have the .lic file as a .lic and not a txt, and it is in the correct place

Message was edited by: Stuart1745  edited for image links

0 Kudos
Message 7 of 18
(2,553 Views)

Dear Stuart1745,

From the Windows Start»All Programs»National Instruments file menu, select "NI License Manager". Expand the Local Licenses section and expand your version of LabVIEW. You should see a list of development systems. Make sure that you have a green box next to the FIRST Robotics Competition entry. If not, right-click on the FIRST Robotics competition entry and select Activate. You should be able to complete the following activation steps and activate over the internet with your serial number.

Best Regards,

Nate

NI FIRST Support

FiRC LabVIEW Activation.png

0 Kudos
Message 8 of 18
(2,553 Views)

Hi Nate,

When viewing my License Manager screen, the "Development System" box is yellow, the "FIRST Robotics Competition" box is yellow and the "Professional Development System with MathScript" is half yellow.  My "Remote Panels" is half green like your example.  The status for "FIRST Robotics Competition" says "Activated for this computer".  The status of "Professional Development System with MathScript" says "For evalution only.  Activation is required for the licensed version".  The status of my "Remote Panels" is "For evalution only.  Activation is required for the licensed version"

On the Getting Started screen when I start LabView, my New list includes only Blank VI, Empty Project, VI from Template... and More....  It does not include the "FRC cRIO Robot Project" or "FRC Dashboard Project" shown in the "FIRST Robotics Competition: Joystick Motor Control in 10 Minutes" video currently available on the Community Spotlights web page.

What do I need to do next to complete the licensing or install?

Thanks,

John

0 Kudos
Message 9 of 18
(2,553 Views)

Ok well what finaly worked for me was removing all NI software, going back to make sure the .lic was in the correct folder as the correct type, then going and reinstalling labview. When I did that I was able to activate labview normaly. thanks nate for the help.

0 Kudos
Message 10 of 18
(2,553 Views)