Showing results for 
Search instead for 
Did you mean: 

unable to extract the data from the DIAdem DataFinder search using Data-finder toolkit in LabVIEW 2009

Go to solution

I am facing problem in fetching the data from the DIAdem Datafinder.


Initially, I have developed this project in LabVIEW 2010. But due to some probelm that i faced in LabVIEW 2010, I thougth of working on the project in LabVIEW 2009.

So, i reused the project that i created using LV 2010 using save-for-previous-version option.


When i tried to fetch the data from the DIAdem using Data finder toolkit. I got a warning 305505. Please see the attached Warninig message.


But i didnt see this warning while i was working in LabVIEW 2010 and also, I was able to get the data from the DIAdem.


Please suggest me a way to solve this problem.

0 Kudos
Message 1 of 6

Try building the project again in LabVIEW 2009

0 Kudos
Message 2 of 6

The warning says that your search returns results of files which are no longer available. This may happen if the file has been deleted and the index has not been updated yet or a network drive is no longer available. Updating your index may help to solve the problem. To update your index click right on the DataFinder tray icon, select "Configure...", go to the "Indexer" tab and select "Start Now".

If updating your index does not solve the problem I´d be more than happy to take a look at your VI. You can post it or you can send it to eva DOT tilp AT ni DOT com




0 Kudos
Message 3 of 6

Hi Eva,


I have tried resetting the DIAdem Index, but the problem still exists. But I want to let u know that I have created my own Data Plugin using LabVIEW SDK. Earlier i was working on the dataplugin that i created using LabVIEW 2010 and I was getting the warning 305505.


I thought error might me due to this mismatch between LabVIEW 2009 and LabVIEW data plugin in 2010.


So, I created the data plugin in LabVIEW 2009. But I am getting different warning message 305504. Even while executing, "Result to Waveform.vi" in Data finder toolkit searches for "lvStorage.dll" in the following location: "C:\Documents and Settings\All Users\Application Data\National Instruments\Shared\USI\Plugins\DataPlugins\LabVIEW_Excel_DataPlugin\data".


It seems to be strange that before searching the dll, LabVIEW actually renames the "lvStorage.dll" in to "lvStorage.dll_", and then it searches for the dll. 


This has never happened with dataplugin that i have created using 2010.


Please suggest me a solution to avoid this probelm and possible reasons for this?


I have attached the sample code.




0 Kudos
Message 4 of 6
Accepted by topic author Alagar Anand

Hi Alagar,
there is a bug when using the DataPlugin SDK in combination with DataFinder Toolkit 2009.
This bug is already fixed in LabVIEW 2010 and DataPlugin SDK 2010. But as you said there is another issue in LabVIEW 2010 which forces you back to LV 2009.
I would suggest to use LabVIEW 2009 with DataPlugin SDK 2009 and DataFinder Toolkit 2009, and instead of using the "Results to Waveform.vi" to read the search results I would recommend to use the Storage VIs. I have extended your example VI and attached it to this post. You will still see the dialog searching for "lvStorage.dll" but it will disappear automatically and the VI is working anyway because in this case LabVIEW will find the dll on its own.
My extended VI uses the "_openWithRoot.vi" to open a file with a different DataPlugin than TDM or TDMS. This VI is also described in the follwing knowledge base article: http://zone.ni.com/devzone/cda/epd/p/id/4181
With LabVIEW 2010 the DataPlugin support has been improved and completely integrated into the standard palette of the Storage VIs. So in LabVIEW 2010 you could replace the "_openWithRoot.vi" with the standard "Open Data Storage.vi" but with LabVIEW 2010 you are also able to use "Results to Waveforms.vi" to read the search results.

I hope this helps.


Message 5 of 6

Hi Eva,


Thanks for your reply.


It is working well with the changes that you proposed.


Also, i would like you to have a look at the link below.  This post corresponds to the issue that i faced with LabVIEW 2010 Application Web Server port.



Kindly, go through the post and if possible help me in solving the issue.




0 Kudos
Message 6 of 6