NI Home > Community > NI Discussion Forums
Reply
Member
THANG NGUYEN
Posts: 70
0 Kudos

Send email on labview using the Gmail Server (TLS)

Hello,
I am trying to using the Google mail server to send email from LabVIEW. I actualy try to use the library of the OpenG OGIC_SMTP. The problem is when talking with the server, I received the message require to do TLS. After sending STARTTLS, I receive this message 220 2.0.0 Ready to start TLS. I don't know what I should do next.
Please tell me what is the next step? I do a lot of googling but only the recommend that after TLS is negotiate with the server. But I don't know how to do that.
I highly appriciate any help.
Best Regards,
Thang Nguyen
Trusted Enthusiast
TCPlomp
Posts: 3,097
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

Hello Nang,

It would us if you could show which code you used and which protocol you (try to) follow!

Ton
Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
Member
THANG NGUYEN
Posts: 70
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

Hi TonP,
Could you please take a look at the VI OGIC_SMTP_Main.vi in the internet toolkit at OpenG? http://openg.org/tiki/tiki-index.php?page=OpenG+Internet+Connectivity+Tools#attachments
You can download at the attachment tab.
Because I still try to modify this function with adding some command, so there is not any vi from myself. That's the reason why I don't have any VI to send you.
Thank you for your patient to answer my question.
Thang Nguyen
Active Participant
Jim_Kring
Posts: 1,742
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

I have answered your question, here.
Thinking in G
Member
THANG NGUYEN
Posts: 70
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

Hi Jim,

I read your answer already. I just want to answer TonP.

Thank you so much for your answer,

Thang Nguyen

Member
Eriquito
Posts: 159

Re: Send email on labview using the Gmail Server (TLS)

I managed to accomplish this fairly easily using the Microsoft .NET Framework.  Of course, that means it will only work in Windows for the time being.  See the attached gmail.vi.
Eric V
National Instruments
Applications Engineer
Certified LabVIEW Associate Developer


"I'm a Ramblin' Wreck from Georgia Tech and a helluva (NI Applications) Engineer!"
Member
minitor
Posts: 8
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

I have used this gmail VI with decent success.  However, when I attach a file, it seems to leave the file open so that I cannot open it elsewhere in the program.  Is there  a way to fix this?

 

Thanks,

 

Andy

Trusted Enthusiast
TCPlomp
Posts: 3,097

Re: Send email on labview using the Gmail Server (TLS)

[ Edited ]

I assume that if you close all of the refernces you should have no problem:

 

 

Ton

 

Message Edited by TonP on 10-04-2008 11:12 AM
Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
Member
EricH
Posts: 1
0 Kudos

Re: Send email on labview using the Gmail Server (TLS)

If possible, could some one please post a version of 'gmail.vi' for LabView 8.2?  Thanks!

Knight of NI
Posts: 18,064

Re: Send email on labview using the Gmail Server (TLS)

Here you go.