VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Veristand Error -1074384767 while deploying

Solved!
Go to solution

Hi,
I have a Veristand Project configured with XNET hardware.  When I deploy my project, I receive the following error:

The VeriStand Gateway encountered an error while deploying the System Definition file.

 

Details:
Error -1074384767 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> Project Window.lvlib:Connect to System.vi

 

Possible reason(s):

 

NI-XNET:  (Hex 0xBFF63081) The database specified could not be opened. Solution: Check that the alias and/or the file exist and that it is a valid database.
=========================
NI VeriStand:  XNET Database Deploy.vi:5260001
Database Alias: 
A possible fix could be either to open the XNET Database Editor and register a FIBEX file under this Alias or open System Explorer and replace the XNET database.


The thing is, I had LabVIEW 2017 and Veristand 2017. I got Veristand upgraded to 2024 unintentionally and along with that NI XNET and other packages also got updated. I then uninstalled the 2024 VeriStand downgraded XNET to 17.0. I have attached the screenshot of NI Package manager showing these versions also. 
I am new to Veristand and this project was actually not created by me. Do anyone know how to solve this error.

Download All
0 Kudos
Message 1 of 6
(375 Views)

Follow the instructions in the error message and Deploy XNET Database into Real-Time Targets

-------------------------------------------------------
Control Lead | Intelline Inc
0 Kudos
Message 2 of 6
(354 Views)

Hi,


@ZYOng wrote:

Follow the instructions in the error message and Deploy XNET Database into Real-Time Targets


Thanks for your reply. When I try to deploy the XNET database, after connecting to the RT target, I can see that all these databases are already deployed to RT. And now I am getting a different error when trying to deploy. 


The VeriStand Gateway encountered an error while deploying the System Definition file.

 

Details:
Error -1074384875 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> Project Window.lvlib:Connect to System.vi

 

Possible reason(s):

 

NI-XNET:  (Hex 0xBFF63015) This indicates that a NULL pointer or an empty string was passed to a function. The user should verify that the parameters passed in make sense for the given function.
=========================
NI VeriStand:  XNET Database Deploy.vi:5260001
Database Alias: 
A possible fix could be either to open the XNET Database Editor and register a FIBEX file under this Alias or open System Explorer and replace the XNET database.

 

 

I have attached both the screenshots. 
Thanks and regards, 
Anjali

 



Download All
0 Kudos
Message 3 of 6
(327 Views)

I suspect that your drivers are messed up. NI drivers are usually downward compatible for 4 versions only. NI-DAQmx 2024 Q1 is not compatible with VeriStand 2017.

I would recommend you delete all drivers and reinstall the compatible version.

-------------------------------------------------------
Control Lead | Intelline Inc
Message 4 of 6
(310 Views)
Solution
Accepted by topic author anjalihari

@anjalihari  ha scritto:

Hi,


@ZYOng wrote:

Follow the instructions in the error message and Deploy XNET Database into Real-Time Targets


Thanks for your reply. When I try to deploy the XNET database, after connecting to the RT target, I can see that all these databases are already deployed to RT. And now I am getting a different error when trying to deploy. 


The VeriStand Gateway encountered an error while deploying the System Definition file.

 

Details:
Error -1074384875 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> Project Window.lvlib:Connect to System.vi

 

Possible reason(s):

 

NI-XNET:  (Hex 0xBFF63015) This indicates that a NULL pointer or an empty string was passed to a function. The user should verify that the parameters passed in make sense for the given function.
=========================
NI VeriStand:  XNET Database Deploy.vi:5260001
Database Alias: 
A possible fix could be either to open the XNET Database Editor and register a FIBEX file under this Alias or open System Explorer and replace the XNET database.

 

 

I have attached both the screenshots. 
Thanks and regards, 
Anjali

 




I can see from the image (34) that you have not yet associated any aliases with your dbcs.You need to create an alias for each dbc you use in your project.

Message 5 of 6
(202 Views)

@Anto_F91 wrote:

I can see from the image (34) that you have not yet associated any aliases with your dbcs.You need to create an alias for each dbc you use in your project.


Hi Anto,
Yes, you are right. The aliases associated with the dbcs were missing. I added it from the XNET Database editor, and I was able to deploy the project successfully.
Thanks for your support.
Anjali

0 Kudos
Message 6 of 6
(173 Views)