VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Playback of an array from labview

Solved!
Go to solution

My workaround was to edit MaxItemsInObjectGraph in machine.config

 

under system.serviceModel I added

 

<commonBehaviors>
	<endpointBehaviors>
	<dataContractSerializer maxItemsInObjectGraph="2147483647"/>
	</endpointBehaviors>
	<serviceBehaviors>
	<dataContractSerializer maxItemsInObjectGraph="2147483647"/>
	</serviceBehaviors>
</commonBehaviors>

 

 

then I had another error regarding .NET, and I figured out it was about some buffer size, so I added to system.serviceModel in machine.config

 

<bindings>
<netTcpBinding>
<binding name="netTcpBinding" closeTimeout="00:10:00" openTimeout="00:10:00" sendTimeout="00:10:00" listenBacklog="100" maxBufferPoolSize="2147483647" maxBufferSize="2147483647" maxConnections="100" maxReceivedMessageSize="2147483647">
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
</binding>
</netTcpBinding>
</bindings>

Anyway, your solution is way better, as editing machine.config is something I'd like to do only on my machine.

 

As a suggestion: would it be possible for the veristand .NET API to handle these exceptions, and eventually to give me the option to edit this parameters in the code, like I do in other languages?

 

Thanks,

 

 

Matteo

Message 11 of 12
(2,842 Views)

Hello,

 

VS2011 SP1

 

We have experienced the same issue. Modification of machine.config works. Knowing the WFC for the gateway can be tuned by "C:\ProgramData\National Instruments\NI VeriStand 2011\NIVeristandService.xml", is it possible to specify the new quota into this file instead of machine.config ?

 

attached: our current NIVeristandService.xml settings.

 

Best Regards

0 Kudos
Message 12 of 12
(2,692 Views)