Showing results for 
Search instead for 
Did you mean: 

Error when loading system definition file

I am working on the development of a test stand running Veristand 2020.  Several times over the last few months, I've made a change to the system definition file, saved it, then tried to deploy, only to get the following error:


Load Error

An error occurred while trying to load "C:\...<project name>.nivssdf", The source file format is invalid.


In every case, the ultimate solution has been to start a brand new project, then bring in all of the project items (sdf, screens, calibrations, logging spec, etc.).  It seems something gets corrupted in the process of saving a change.  Has anyone ever encountered this?  At this point we are just making small changes, like adding a calculated channel, so it's not like there are a lot of changes being made that could break stuff.

0 Kudos
Message 1 of 4

Hi again _pepper,

That sounds frustrating. You shouldn't have to periodically make a new project from scratch. Would like to get to the bottom of this and find some better workaround for you.


Once you have such a corrupted SD file... In terms of trying workarounds, I would first recommend creating a copy of the project (to serve as a restore point) before messing with anything. A few things to subsequently try would be the following (performing each action before attempting to open the project/deploy):


1. Delete the .cache folder that is a sibling of the files of the project. (This includes both the cache for the system definition and the project itself.) Note that this will cause settings such as currently open project windows/tabs to be lost.


2. If #1 does not solve the problem, open the system definition file (.nivssdf) in a text editor and delete the <Property Name="ChannelDiagrams"> XML element near the top of the file. Note that doing this may cause the mapping diagram to regenerate the layout of its content--any custom arrangement, positioning of nodes, bundling of wires, etc. could be lost.


3. If neither #1 or #2 works in isolation, attempt both of them simultaneously before attempting to open the project. (Make sure neither the .cache folder nor the ChannelDiagrams property is present.)


Please let us know if these ideas get your SD file back into a happy state.


And if you can isolate what is the change that is corrupting things; like if you had a snapshot of your SD before (no error) and after (SD error on deploy) that would be immensely helpful to us in figuring out what the root cause is.  If you can figure that out, I'll get the Bug made and dealt with on the NI R&D side.

Darin Gillis
NI - Chief Product Owner - VeriStand
0 Kudos
Message 2 of 4

I have the same issue and have tried all three steps without success. This has happened multiple times already. Is there a way to prevent it? or any additional steps to fix it?

0 Kudos
Message 3 of 4

We have some similar concerns (i.e. I will try the removal of the <Property Name="ChannelDiagrams"> for this.

To limit the damages we use a source control tool (SVN or GIT) and use to commit any (even minor) change that works. So in the case of a weird issue we can (at least) check the changes between the versions.

Your error sounds like the XML is no more consistent, maybe because some object (text, image, ....) is not well encapsuled by VS.

Hope you'll find something

0 Kudos
Message 4 of 4