VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

AMESIM model with VeriSand

Hello,

 

I currently have a project to design an HIL bench based on VeriStand. I expect to have some real-time targets running on VeriStand (LabVIEW-RT / Linux64) synchronized and in a reflective memory ring.

 

The point is to run AMESIM® models along with the Simulink® ones in this system.

 

The preferred solution would be VeriStand to be able to load the models from the AMESIM® FMU.

A second option would be to load those models in Simulink® (maybe as black boxes) and build a “.so” from RTW that can be uses by VeriStand.

At least, if previous are not possible, run those models on a real-time (or even pseudo real-time) device connected to the reflective memory ring. In this later case, what is the required device and software support?

 

Any advice will be appreciated.

HAGD

0 Kudos
Message 1 of 11
(3,008 Views)

Hello thumble, 

I think this article can help you to find your answers about supported models and configuring them. 

 

Regards

0 Kudos
Message 2 of 11
(2,861 Views)

If you want to explore the FMU route, you can find more detail on VeriStand's native FMI/FMU support here:
https://www.ni.com/docs/en-US/bundle/veristand/page/fmi-early-access.html

and VeriStand's FMI limitations here:

https://www.ni.com/docs/en-US/bundle/veristand/page/fmi-limitations.html

 

best of luck, post here to let us know how its going!

-Darin

Darin Gillis
NI - Chief Product Owner - VeriStand
0 Kudos
Message 3 of 11
(2,851 Views)

Hello, have you solved this problem now? If so, could you please provide me with the software to be installed and a brief overview of the process? I would greatly appreciate it.

0 Kudos
Message 4 of 11
(2,401 Views)

In short: you have to use amesim installed on linux. There you follow the instructions from the built-in help:
1 choose interfaces - functional mock-up interface
2 fixed step
3 interfaces - export FMU
4 cosimulation 2.0, GNU GCC 64 bit

 

one more important note: veristand 2021 R3 and later has a known bug: it gives you a loading error when you load the model via the system configurator. You have to choose to add the file from the interface.

0 Kudos
Message 5 of 11
(2,397 Views)

Hello, I would like to create an interface from AMESim software to VeriStand, and then compile it for the connected CRIO9047 controller in VeriStand. However, I'm getting an incompatible error. When I went back to AMESim, I found that the VeriStand interface can only be compiled using a 32-bit compiler, which is causing the incompatibility between the two. Do you have any suggestions or solutions for this issue? Thank you very much!

0 Kudos
Message 6 of 11
(2,345 Views)

Amesim installed on PC with Linux?

0 Kudos
Message 7 of 11
(2,330 Views)

I am using VeriStand on my computer to connect to a CRIO9047 controller, which runs on a Linux operating system. I want to load a DLL file compiled with Amesim into the 9047 controller using VeriStand. However, I'm getting an incompatible error during the loading process, and I suspect it's because the compiler can only work with 32-bit dependencies. Do you have any solutions for this issue?

0 Kudos
Message 8 of 11
(2,328 Views)

If you have Windows installed on your computer where you compile the models, you cannot compile FMU for Compactrio (linux). Install Linux on your computer, install amesim for linux, and compile the FMU as I wrote above.

0 Kudos
Message 9 of 11
(2,290 Views)

Hi thumble,

Have you solved this problem? Now I have the same problem. Could you tell me the solution? Thank you very much.

0 Kudos
Message 10 of 11
(1,682 Views)