USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

ni USRP Error -1074118643

Hello everyone,

I am working with ni USRP 2920, the installed driver is version 14.0, LabVIEW 2012, Windows Enterprise 7.

I want to use my usrp as transmitter it actually works pretty fine, still I set the time new sample should be generated. Then, I got the following Error : -1074118643

                        "niUSRP Write Tx Data (CDB WDT).vi<ERR>Packet had timestamp that was late (or too early)."

 

I tried to change the positions of niUSRP Set time.vi and niUSRP Configure trigger.vi as recommanded for drivers vers. 1.1 and 1.2. Unfortunately it doesn't work.

 

It doesn't matter if I left the polymorph vi niUSRP configure trigger.vi to automatic or select Start trigger time. The same error occurs.

 

Do anyone make the same experience? if yes! what is the work around to be made?

 

Thanks for your reply.

0 Kudos
Message 1 of 4
(5,733 Views)

You need to use the niUSRP Configure Trigger.vi to set the time you want the waveform to start generating.  You must also use the niUSRP Set Time.vi to actually set the time on the device.  Are you doing both of these and making sure the Configure Trigger time is sufficiently after the time you set at Set Time for the device to be ready to generate in time?

 

See the following example for more details:

 

<Program Files>\National Instruments\LabVIEW 2014\examples\instr\niUSRP\niUSRP EX Tx Finite Sync.vi

0 Kudos
Message 2 of 4
(5,716 Views)

Of course I did it.

How does these functions working?

I thought ni Configure trigger.vi specified the time the usrp should generate the first samples. Thus deter it from doing so still that time. Seemingly it is working differently. Indeed the niUSRP Configure trigger.vi set when to generate first samples however, it does not prevent it to do so.

Am I right? If so, Then I would have to set trigger time such that roughly on that time first samples get at niUSRP write.vi.

0 Kudos
Message 3 of 4
(5,681 Views)

hi psisterhen,

another remark I have made regarding my application is that I do not sent finite data length as in the mentioned example. Either, I've specified the time to generate the first sample and from that time on I continuous sending uninteruptly. It actually work the first time I run the vi. Then I stopped and restart again. That is then I get the above error.

 

It there a work around to make the USRP  sends samples continuously from a specific time?

 

thanks for reply

0 Kudos
Message 4 of 4
(5,664 Views)