USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

How can I reset the USRP IP address to the default 192.168.10.2?

Q: How can I reset the USRP IP address to the default 192.168.10.2?

 

A:

First, try to set the USRP IP Address using the NI USRP IP Configuration Utility included with the NI-USRP driver. When doing so, ensure that the network adaptor for the PC that will run the utility is set to a static IP address that is on the same subnet as the current IP address of the USRP you wish to change.   If the IP for the host PC is set to a static IP this way, the USRP (with the current IP address) should appear in the list presented by the Utility. You can then select the USRP from the list and enter a new IP address such as 192.168.10.2 for it.  If you aren't able to see the USRP listed in the NI USRP IP Configuration Utility, it's likely that the USRP is on a different subnet than your host PC network adaptor. 

 

Try the above suggestion first--but if the above isn't feasible, the USRP can be booted into a safe (read-only) image in which the device will be set to the default IP address of 192.168.10.2. Doing so requires opening the USRP enclosure--take appropriate static precautions when doing so. The safe-mode button is a pushbutton switch (S2) located inside the enclosure. To boot into the safe image, hold-down the safe-mode button while power-cycling the device. Continue to hold-down the button until the front-panel LEDs blink and remain solid. 

When in safe-mode, you can then run the NI USRP IP Configuration Utility to change the IP address from the default (192.168.10.2) to a new value. 

I recommend plugging the USRP on a network without any other USRPs to the PC that will run the utility to update the IP address--doing so avoids the possibility of an IP address conflict. Also, make sure that the network adapter on the PC that will run the IP address update is set to a static IP address of for instance 192.168.10.1--the host PC IP address needs to be different than the 192.168.10.2 and the different from the new desired IP address for the USRP

 

Sam Shearman
Message 1 of 10
(15,908 Views)

Note that if the host computer network adaptor is set to the same subnet as current IP address of the USRP, the NI USRP IP Configuration Utility can change the IP address of a USRP to a new address that isn't necessarily on the same subnet.

 

For instance, if you connect to a USRP with a current IP address of 192.168.10.2 using a host PC with a network adaptor set to a static IP address of 192.168.10.1 with a subnet mask of 255.255.255.0, you can in invoke the NI USRP IP Configuration Utility to change the USRP address to something new, say, 192.168.11.2. When you then reboot the USRP, the IP address change utility may show the USRP in question in the list of connected USRPs, but you won't be able to successfully change the IP address w/o first changing the network adaptor static IP address to something like 192.168.11.1, with a subnet mask of 255.255.255.0.

Sam Shearman
0 Kudos
Message 2 of 10
(15,892 Views)

My USRP-2920 suddenly was not reachable through the IP which I set at the very beginning. Therefore I put it in safe-mode via the S2 switch and the NI-Configuration Utility was able to display the USRP with the standard IP. After setting a new IP address and a reboot the USRP cannot be found again. 

 

I also noticed that the NI-Configuration Utility displays Unknown Revision under Type/Revision. A FW and FPGA image update was successfull, but after the reboot the USRP cannot be found again. I have tried to flash the original images (ni292x_) and the usrp2_-images.

 

How can I solve this problem?

0 Kudos
Message 3 of 10
(14,422 Views)

Does anybody have a idea?

0 Kudos
Message 4 of 10
(14,394 Views)

Hi

 

Try connect a terminal program to the serial output J305(you need a standard USB to 3.3v-level serial converter) there it wil output the current IP address and other debug information , i think the serial rate is  230400 baud

(use GND to the converter ground, and TXD to the converter RX)

0 Kudos
Message 5 of 10
(14,387 Views)

Hey YYY,

 

When you see the Unknown Revision in the configuration utility, are you in safe mode?  

 

Are you able to find your device at all when you are not in safe mode?

 

You know the IP address that you last set your device to, does it respond to a ping in the command line?

 

Unfortunately, it sounds like the EEPROM may no longer be functional.  I have seen this issue before and replacing the EEPROM has fixed it.  I want to make sure we do all of the necessary troubleshooting before I recommend sending the unit in for repair, so let me know.

Sarah Yost
Senior Product Marketing Manager
0 Kudos
Message 6 of 10
(14,379 Views)

Hey YYY,

 

Also, what color are all of the front panel LEDs when you are booted normally?  And booted in safe mode?

Sarah Yost
Senior Product Marketing Manager
0 Kudos
Message 7 of 10
(14,376 Views)

Hi Sarah_Y,

 

yes, the unknown revision is visible in safe mode. In normal mode, the configuration utility shows nothing.

 

No, it's not responding to it's old IP and also not the new IP (which was set without erros in safe mode with a reboot afterwards).

 

In normal and safe mode only LED D and F is green. The other LEDs are off.

 

Best regards,

YYYs

0 Kudos
Message 8 of 10
(14,343 Views)

Unfortunately my USRP is out of warranty. I did not know that there is only 1 year warranty for the USRP in Germany. The support offered me a repair for 1700 €, which is pricy in relation to the price for a new USRP 2920. I guess I will let them send it back to me and try to repair it on my own.

 

Can you tell me more about the EEPROM replacement? Since the NI-USRP Configuration Utitlity is not working I have to chose another way. Can I maybe use the usrp_burn_mb_eeprom which was mentioned in http://forums.ni.com/t5/USRP-Software-Radio/Help-Configuring-Network-Settings-on-USRP-2920/m-p/24021...?

 

I will try ORNs advice in the meantime. I appreciate any help, also per private message.

 

Best regards,

YYYs

0 Kudos
Message 9 of 10
(14,218 Views)

Hello, had the same problem, updating the firmware under safe mode solved it.

0 Kudos
Message 10 of 10
(6,798 Views)