From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

SystemLink Forum

Showing results for 
Search instead for 
Did you mean: 

Read Tag History does not work without API key

Hi there! Hoping someone could help me navigate this issue. I have created a simple webvi to graph some sensor values saved as tags (doubles) using the "Read Tag Hisory" function on SystemLink cloud. When I am testing it on GWeb with API Keys, everything works fine and I get a nice plot of my sensor values. However, when I go to deploy this webvi to SystemLink cloud and remove the configurations (set to Auto), "Read Tag History"  doesn't return any values and my graphs remain empty.


I've tried to debug in a few ways:

  • Indicator arrays from "Read Tag History" are all greyed out and show zero 
  • I can receive other double or string type tags using the "Read Tag" vi. When I replace "Read Tag History" with "Read Tag" it works to return a single value
  • I've tried to allow all permissions for this uploaded WebVI this didn't work
  • Uploaded the WebVI with the API keys embedded with read only permissions (I know this is bad practice but just wanted to see), and this worked as expected

It seems the "Read Tag History" function only works in my case when there is an API key attached but am I doing something wrong? Is there a workaround to this?


Greatly appreciate any help here!






0 Kudos
Message 1 of 1