Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO 9073 Inconsistent IP Settings

I have a cRIO 9073 connected to a PC via a crossover cable. I set-up the fixed IP on the pc as, gateway of


I switched the IP Reset to On, rebooted and switched IP Reset to off.


Under MAX, I found the cRIO, I was able to change the IP in a off-line fashion (right click on 'remote system') to, but I get an 'IP Inconsistency' message.


Some advice, please?

0 Kudos
Message 1 of 10

You stated that you had set the PC to a static IP address. Is the cRIO set to have a linked-local IP address? This is the most common reason for this problem and is documented in a KnowledgeBase. If those solutions don't work, another option may be to delete the target in MAX and re-add it to the network.

Stephanie A.
Americas Marketing Manager
National Instruments
0 Kudos
Message 2 of 10

thank you so much for the reply, that helps a lot.


What I would like to also ask is, since it's a bit unclear to me at this point,  if it is possible to interact with the compactRIO over the Internet and NOT ONLY over a subnet scenario.


(to be more detailed, we plan on deploying our cRIO to a remote location where it would be monitoring several parameters.The device itself was chosen by our predecessors, and we have been told that it should do the trick.

Now, as one may imagine, we are trying to understand their choices and decisions so far, including making sure that the cRIO is actually able to communicate over the internet to a remote machine)


To my understanding so far, one can easily find walkthroughs and support for 2 scenarios:

i) direct link to a pc (crossover cable)

ii) on-the-same-subnet link. question is if there is a 3rd scenario:

iii) connection over the internet.






0 Kudos
Message 3 of 10

hey all,


before someone helps me with the question above, if there is help for that matter, I actually have some progress generated by StephanieO's input (thank you again for that):

i) I booted the cRIO with IPReset and Safe Mode ON, and I was able to set-up an IP for the cRIO, usign a suggested one.

ii) I toggled the Safe Mode and IPReset to OFF and disconnected the cRIO from my pc, and plugged into the local network switch.

iii) I rebooted it, while connected, via the same crossover cable, to the network switch, and was able to add it to my remote systems.

iv)I was able to install software on it, the suggested one by the MAX given option.


Note that these steps are indicated in the following walkthrough:


Now, I get stuck at step no. 4-5 of the following:


What happens at this step, is that if I expand 'My Systems' and select my cRIO I don't get an empty window. No CPU Memory, no Scan Engine, nothing.

At the same time, if I return to MAX to inspect, on the very same place it said 'Inconsistent IP Settings' now it says 'Safe Mode (Improper Installation)' which is being seconded by the status LED blinking twice, indicating a flawed software install (see attached image).


Honestly, I don't know what I am doing wrong, since I followed NI's tutorial to the letter. (like stated above, this is it:


I am starting to wonder if choosing this hardware was the right choice, since there are problems all over the place. Sure, the forum community does a great job at helping, but that is my point exactly: there shouldn't be the need for such a community, if the product would have been well developed/matured and followed-up with sufficient documentation.



Anyways, looking forward to someone providing some help here as progress taming this thing is slow and painful.


best regards,


0 Kudos
Message 4 of 10



To address your first question, from what I understand you want to communicate with this cRIO in a remote location. Are you trying to pass data from the cRIO. You can communicate and pass data over UDP or TCP connections to communicate to a remote cRIO. You cannot make a connection to a cRIO over the internet like you can with a direct connection to a host or if the target is on the same subnet. You can look at devices not on the same subnet by right-clicking on Remote System»Create New..»Remote Device (not on the local subnet).


When getting the Improper Installation error, did you try reformatting the cRIO? Sometimes reinstalling the software will do the trick. Here is some more information about doing this. Did that error occur immidetely after installing the software? Or only after you tried to add it to the DSM?

Stephanie A.
Americas Marketing Manager
National Instruments
0 Kudos
Message 5 of 10

Hi all,


I am also suffering this problem with inconsistent IP address.


The cRIO was working perfectly well without the module for a couple of days. When i installed the modules into the RIO, it still worked fine.

But when i unplugged the modules and rebooted the RIO, the inconsistent IP address problem occured. Anybody have any experience like that? 

BTW we are using DHCP connection.



0 Kudos
Message 6 of 10



Could you please post this in a new topic (forum here)? Because of the age of this thread you will be best assisted in this way.



Craig H. | CLA CTA CLED | Applications Engineer | NI Employee 2012-2023
0 Kudos
Message 7 of 10



Thanks for the quick reply, the problem has been solved this morning.

I think that s the problem caused by the network server.



0 Kudos
Message 8 of 10

also has problem with IP adress

I already tried to change at the network setting 

can any one help me to configure this compact rio,

what the problem suppose. how to solve this.

0 Kudos
Message 9 of 10

Hi MSyafiq,


Typically, inconsistent IP settings means that your cRIO and your PC are on different subnet addresses.  Have you looked at the following link to see if you can change your subnet to match?  Additionally, this is a rather old thread.  If you are still having issues, you will have better luck with our community by posting a new forum thread with information about your device and hardware setup that more people will read.  Hope this helps!


Configuring cRIO for First Use

| Zach J. | Systems Engineer, HIL and Test Cells | National Instruments |
0 Kudos
Message 10 of 10