Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Why the result is different

Greetings,

I written a VI, in which I first initialize a 2d array, Then Pass this array to a Call Library Fuction Node. In correspoinding DLL, I change the arrary value. At the end, I store the 2d array in a file. I run this VI in a host compulter, all is fine, I can get the expected result. However, when I run it in RT target, the result is different, it seems that the DLL could not change the array value. Why this happens? Attachment are the VI and the DLL with its Labwindows/CVI code. Thank you for your time!

Regards,
Haifei
Download All
0 Kudos
Message 1 of 3
(3,655 Views)

Hi Haifei,

Thanks for posting on the discussion forums.  One thing you can try is using the DLL checker that can be found in this great KB.  I would look over that KB, and check out the links at the bottom of the page.  Also, you need to make sure if you are hard coding the path to find the dll, that it is looking in the right spot on the Real-Time target.  I hope this helps you out.

Regards,

Michael
Applications Engineering
National Instruments
Message 2 of 3
(3,585 Views)

Hey Michael,

Thank you for your time. You are right. After I adding the DLL to the RT project, it works the same as in host computer now.

 

Regards,

Haifei

0 Kudos
Message 3 of 3
(3,579 Views)