Showing results for 
Search instead for 
Did you mean: 

NI MAX upgrade / configuration issue

I recently upgraded a deployment machine from my development machine (remotely, headless). The program will not run since the some cards do not respond.Labwinows / CVI 2017 64 bit deploy.


Upon opening NI MAX, I see similarly named copies of several of the cards with identical aliases. Through software resets, I can determine which are the doppelgangers. I try to delete them and no go. I change the conflicting aliases. Program still cannot resolve instrument. Restart does not help. Shut down,hike across the lab, and reboot. The dopplegangers are still there.


I s there any quick way to erase all data and have NI MAX start anew? Else I will likely have to uninstall NI MAX to fix issue.


Attached in NI MAX report and screen capture.


Thanks in advance,


Download All
0 Kudos
Message 1 of 4



Thank you for posting your MAX report and screwup image. They were very helpful in allowing me o understand the issue you were seeing.


I believe what you are looking to do can be accomplished by resetting the NI MAX configuration data. This will allow you to reset NI MAX and 'start anew' as you mentioned. You can find instructions on how to do this here:


How to Fix or Reset the NI MAX Database File



I hope this helps!

Patrick O.
Applications Engineering
National Instruments
0 Kudos
Message 2 of 4

Well I went  1 for 2 on resets.


I erroneously remote logged on to the Dev system and wiped it clean. Doh! No big deal really but coffee should have been applied before jumping into this.


I was able to reset the deployment but curiously the ghost are still there. I think the values were all set to default name values but the ghosts can still not be removed. I will try to shutdown and restart again and see if that helps.


Nope. I am going with the classic "uninstall it all".


Thanks for the prompt suggestion and it should have worked.





0 Kudos
Message 3 of 4

Uninstall / reinstall fixed the issue.

0 Kudos
Message 4 of 4