NI VeriStand Add-Ons Discussions

Showing results for 
Search instead for 
Did you mean: 

Scan Engine & EtherCAT Custom Device Feedback

Welcome to the Scan Engine & EtherCAT custom device feedback forum. Please  provide questions or comments with regards to this custom device in  this forum.

Message 1 of 676

I'm trying too deploy the Scan Engine @ EtherCAT Custom Device on a cRIO-9024 with a 4 slot chassi in Veristand 2010. If a configure the custom device with no modules their is no problem to deploy to the cRIO. If I add any modul or modules to the chassi and also add them in the custom device I get the errorcode: 537702 According to the documentation of the Scan Engine custum device: "There was a mismatch between the modules configured in the system definition and what was detected on the target system." I have attached the complete deployment log below. What is wrong?

Henrik Ulfhielm


• Loading System Definition file: C:\Dropbox\Novator\Veristand\DEMO Volvo CE\DEMO Volvo CE.nivssdf

• Preparing to deploy the System Definition to the targets...

• Compiling the System Definition file...

• Initializing TCP subsystem...

• Starting TCP Loops...

• Connection established with target AEcRIO9024.

• Sending reset command to all targets...

• Preparing to deploy files to the targets...

• Starting download for target AEcRIO9024...

• Opening FTP session to IP

• Processing Action on Deploy VIs...

• Gathering target dependency files...

• Downloading DEMO Volvo CE.nivssdf [109 kB] (file 1 of 7)

• Downloading DEMO Volvo CE_AEcRIO9024.nivsdat [262 kB] (file 2 of 7)

• Downloading Scan Engine RT [111 kB] (file 3 of 7)

• Downloading Scan Engine Timing [19 kB] (file 4 of 7)

• Downloading Scan Engine - RT.llb [10543 kB] (file 5 of 7)

• Downloading Modules.lvlibp [2634 kB] (file 6 of 7)

• Downloading FXP.llb [7302 kB] (file 7 of 7)

• Closing FTP session...

• Files successfully deployed to the targets.

• Starting deployment group 1...

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

The VeriStand Gateway encountered an error while deploying the System Definition file.


Error 537702 occurred at Project Window.lvlib:Project >> NI_VS Workspace ExecutionAPI.lvlib:NI VeriStand - Connect to

This error code is undefined. Undefined errors might occur for a number of reasons. For example, no one has provided a description for the code, or you might have wired a number that is not an error code to the error code input.

Additionally, undefined error codes might occur because the error relates to a third-party object, such as the operating system or ActiveX. For these third-party errors, you might be able to obtain a description of the error by searching the Web for the error code (537702) or for its hexadecimal representation (0x00083466).

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

• Unloading System Definition file...

• Connection with target AEcRIO9024 has been lost.

0 Kudos
Message 2 of 676

Hi Henrik,

One possibility is that there is an FPGA configuration deployed to your target and the slots you are using are not available for scan IO.  However, even without a custom FPGA bitfile deployed, on occaision I have seen the underlying API used by the Scan Engine CD fail to detect modules in a cRIO chassis.  This sounds like the behavior that you're seeing.  Unfortunately I haven't seen this often enough to know why it is occurring, but in the past I have gotten around this by deploying a chassis configuration to the target from a LabVIEW project.  If you do not have LV and LVRT installed, another possibility you might try is uninstalling and reinstalling the NI Scan Engine and EtherCAT components to your cRIO from MAX.  Hopefully this should "reset" your cRIO and allow you to detect the modules properly.

Unfortunately there is not an API currently available to switch a cRIO between Scan Mode and FPGA mode, so I can't offer that functionality through the custom device (the only way to switch currently is from a LabVIEW project).  However, I'm expecting to see this functionality added shortly, at which time I will add it to the custom device.



0 Kudos
Message 3 of 676

Hi Henrik,

if you install NI-RIO 4.0 (August 2011), it is switched to Scan mode by default.




0 Kudos
Message 4 of 676

I am starting a project in LabVIEW 2011/VeriStand 2011. What do I need to do to get this to work in 2011 versions?


0 Kudos
Message 5 of 676

I am trying to use a cRIO-9024 and cRIO0-9118 with VeriStand 2011 and the 2011 Scan Engine & EtherCAT Custom Device.  I have added the custom device in the project explorer and added a local chasis.  I then selected the modules that match my configuation, saved, and deployed.  I get the same error (537702) when I try to deploy the setup.

I have tried reformatting the cRIO and re-installing the software, including the files for the addons.  I have also tried using a LV project to verfiy that the system is in Scan Mode rather that the FPGA interface and have cleared the FPGA memory.

What else could be keeping the add-on from deploying properly?

Thanks in advance for any advice,


0 Kudos
Message 6 of 676


Sorry for the issues and the delayed reply. I hope my post is still useful for you.

One note:you can now (in NIVS 2011) use a setting on the controller page to set the target Scan/FPGA mode... so you shouldn't ever have to use LabVIEW.

First obvious thing would just to be sure Scan Engine is installed to the target through MAX.

There are two ways you can see what modules are actually present and available on the target through software. By looking at these, we can diagnose why the add-on isn't finding them at start up.

  1. The add-on prints a list of detected modules to the console when it starts up. You can see this list on the console by using NI Web Based Configuration & Monitoring. To access this, open your web browser and type in http://<ip address of RT target>
  2. If you have it, use the distributed systems manager to view the target. You won't be able to see module model #s... but you will be able to see "Mod1" Mod2" etc and the variable values.

If the list is different than what is actually physically present... there is a problem somewhere. If it is the exact same as what is physically present... then we need to look at your system definition and make sure that matches what is physically present.

Stephen B
0 Kudos
Message 7 of 676

Note that you will have to redeploy the system definition to get the list regenerated after opening up the console view in your web browser. On cRIO, it will only show new items since you opened it.

Stephen B
0 Kudos
Message 8 of 676

Thank you for the feedback Stephen,

It appears I had several small issues that each had to be resolved.  At first I was losing connection with my cRIO chassis both when working with VeriStand and when working with LabVIEW.  This was remedied when I reformated the cRIO and installed only the required add-ons for the Scan Engine and EtherCAT.  Unfortuantely I did not have the VeriStand RT Engine 2011.0 added, so that appears to have caused some of my issues, 

Once I set up my controller for VXWorks and the correct IP address, I was able to deploy the system successfully.  I added the Custom Device and deployed again, and it deployed successfully.  I then added the local chassis and several modules and configured the first module (a 9219) for a single channel of K type thermocouple.  When I deployed that configuration, I received error 65720.  I removed all modules except the 9219 and updated the configuration, deployed again, and still received that error.  I changed the configuration for that module to be Voltage, and the error went away on deployment.

Is it possible to use the 9219 in thermocouple mode?

0 Kudos
Message 9 of 676

I saw the same thing when I just tried it. You can prevent this error and enable operation by changing the timing mode to "High Resolution" instead of "High Speed". Not sure why high speed wouldn't work though... at least according to the manual of this module it should be fine.

Still looking into it...

Stephen B
0 Kudos
Message 10 of 676