NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Sequence Analyzer Standalone Tool

Solved!
Go to solution

I was having trouble being able to analyze .tsaproj files using the Sequence Analyzer Standalone tool for command line. The .tsaproj file opens in a new window with every new command I run, but there is no signs of an actual analysis occurring when I add the tag /analyze along with other tags. A new window just pops up in TestStand and does not proceed further with any operations. How do I perform an analysis through command line with clicking on the Analyze button on the GUI?

 

Link to command line tool below:

https://zone.ni.com/reference/en-XX/help/370052W-01/tsref/infotopics/sequence_analyzer/

 

Thanks,

Iman

0 Kudos
Message 1 of 4
(2,222 Views)

Have you tried the report flag that's called out in that help doc?

 

AnalyzerApp.exe "C:\My Documents\MyProject.tsaproj" /analyze /report "C:\My Documents\myReport.XML" /quit

I posted a stylesheet on the community a while back that can be used to convert that report to JUnit and fed to a CI server.

https://forums.ni.com/t5/Example-Programs/Converting-TestStand-Sequence-Analyzer-reports-to-JUnit/ta...

 

Another thing that's useful to know is the return codes for the Analyzer, which there is an open CAR to document officially:

-2. Invalid Paths: An invalid path was passed to the AnalyzerApp
-1. Invalid Flags: An invalid flag was passed to the AnalyzerApp.
1. Analyzer Error: One or more Errors were reported when analyzing the project.
2. Analyzer Warning: One or more Warnings were reported when analyzing the project
0. Success: No Errors or Warnings were reported.

Hope this helps!

Trent

 

https://www.linkedin.com/in/trentweaver
0 Kudos
Message 2 of 4
(2,207 Views)

I tried with the report flag and the myReport.xml path, but it still just opens a new window and doesn't do any analysis or create an xml file in a path I specify. The error codes don't show up since the Analyzer never seems to actually run. I'm running TestStand 2014.

 

Thanks,

Iman

0 Kudos
Message 3 of 4
(2,201 Views)
Solution
Accepted by topic author inandi

The command line support for the analyzer wasn't added until 2014 SP1.

-Trent

https://www.linkedin.com/in/trentweaver
0 Kudos
Message 4 of 4
(2,198 Views)