NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Report Failure Chain list all failure

Hello ,


I am using TestStand 2013 and Sequence Editor Version 5.1

TestStand lists only the first failed step and it's sub steps in the Failure Chain under header section of the Report.

I wish to list all the failed steps under Failure Chain.


The following link did not help me.


Has any one had similar requirement and able to implement it ?

Eagerly waiting for your support  🙂




0 Kudos
Message 1 of 9

Hi mikan900,


I have tried the approach suggested in the KB article and it worked for me.


Could you try copying the attached reportgen_html.seq file to <TestStand Public>\Components\Models\TestStandModels and then executing your sequence to see if you get the desired behavior.


Oh, one other thing, and i think this was not mentioned in the KB: For this to work, you have to configure TestStand to use the "Sequence" report generator instead of the "DLL" report generator, since you are essentially modifying the generator sequence in the steps mentioned in the KB.


You can find the option under Configure->Result Processing..->Report Options-> Select a Report generator for Producing the Report Body. Choose Sequence instead of DLL.


Hope this helps.

0 Kudos
Message 2 of 9

Hello TRJ,


Thank you for your reply.

I did copy the reportgen_html.seq to the location you suggested. However, things still don't work for me. I am not sure what I am missing out.


My <TestStand Public>\Components\Models did not have TestStandModels folder. I created one and added Seq file to it.


I set a break point in reportgen_html.seq, but found out that this Seq was not called.

Would appreciate more help from you.






0 Kudos
Message 3 of 9

Hi MK,


I am sure you might have already done it, but just to confirm, have you updated the "Configure->Result Processing..->Report Options-> Select a Report generator for Producing the Report Body" option to Sequence.


If it is still set to DLL, then that could be why the sequence is not getting executed.


Also ensure that HTML Document is selected as the report format. In fact, could use try and use the same settings that i have under Report Options.








0 Kudos
Message 4 of 9

I also stumbled into this problem, but I wanted it to work for xml. I found this guide but it was written for older versions of TestStand. However I got it working by picking the original "reportgen_xml.seq" from the installation directory for TestStand 2016 and modified it in the same manner described in the guide I found above. I just copied the sequence and replace the call to modelsupport2.dll with a call to the copied sequence. Place the file in the <Teststand Public> directory under Components\Models\TestStandModels\ and it works.


To be able to view the Failure chain in ascending order I had to change that in the .xsl stylesheet. Just searched for "CriticalFailureStack" and then found an option for the "for-each" code snippet that can be set to descending or ascending mode.


I attached the modified file to this post if anyone else need it.

0 Kudos
Message 5 of 9


Did you get it work?

I'm actually facing the same issue. I would like to list all the failures in the failure chain in TestStand 2017, the link here is only for the older version.

Thank you very much for your time!


Best regards



0 Kudos
Message 6 of 9

Yes I got it to work in TestStand 2016 as you can see in my previous post. However I haven't updated to TestStand 2017 yet so I don't know if it will work when I do.

0 Kudos
Message 7 of 9


Thank you very much for the reply.

I found out I should uncheck on-the-fly report to make it work.

Best wishes


0 Kudos
Message 8 of 9

Hi J Werner,


I am happy that you managed to solve the problem. I am still stuck with the same old problem. I am using TestStand 2013 and I wish to see the complete failure chain in XML report. Unfortunately I cannot open your sequence as it is saved in TS 2016 version. The link to the example is no longer working. In TS2013 reportgen_xml.seq there is no PutOneResultInReport.seq, so I am stuck with problem. It would be great if you can upload the reportgen_xml.seq for older version (TS2013).



0 Kudos
Message 9 of 9