NI Package Manager (NIPM)

cancel
Showing results for 
Search instead for 
Did you mean: 

Downgrading NI Package Manager

Solved!
Go to solution

Is it possible to downgrade NI Package Manager? I did find this article, but I do not want to uninstall all of my NI software.

__________________________________
Bill Eisenhower
Certified LabVIEW & TestStand Developer
0 Kudos
Message 1 of 2
(218 Views)
Solution
Accepted by topic author CL_eisenwr

Hi Bill,

 

Technically - yes, you can just uninstall NIPM itself using the Add\Remove control panel option per the KB, then download and install the desired older version of NIPM from ni.com/downloads (the Offline button lets you pick older versions).

 

One of the reasons that KB says to uninstall NI software first is because there could be a compatibility problem with the downgraded NIPM. So every NIPM package has a compatibility version attribute (CompatibilityVersion) that declares the version of NIPM that the package was built with. Because NIPM usually adds features every release, that package might utilize some of those features - so its safest to have that package require that version of NIPM (or newer).

 

So, the problem could be that if you have packages installed on the system that were built with NIPM 21.3 for example, and if you downgraded the system to have NIPM 21.0 installed -- then those newer packages might not be handled properly by the old NIPM, such as giving an error on uninstall, or having them not be displayed at all.

 

But, if NIPM itself was upgraded just because of the upgrade banner (and all of the other installed packages are older), it would be safe to downgrade NIPM to a matching older version.

0 Kudos
Message 2 of 2
(180 Views)