NI Linux Real-Time Discussions

Showing results for 
Search instead for 
Did you mean: 

Issue in mounting NFS share on compactRio-9068

Go to solution

I did tried auto option but it did not work either.

Somehow I feel that eth-0 and eth-1 interfaces are up after syetm trying to mount nfs during system power up inititalization. Is it a possiblity?  CompactRio power up console log is shown below. I could see n/w interface details are listed at the end. Not sure if that means those are up only at the end.

    Rebooting... [236433.339130] Restarting system.

    Booting LabVIEW RT...

    INIT: version 2.88 booting

    [    5.485962] generic-usb 0003:0835:8501.0001: claimed by neither input, hiddev nor hidraw

    [    6.803155] generic-usb 0003:0835:8502.0002: claimed by neither input, hiddev nor hidraw

    Applying large UDP packet fix to devices: eth0 eth1... done.

    vm.overcommit_ratio = 81

    INIT: Entering runlevel: 5

   Starting NI Service Locator: done

   Starting NiRioRpcServer: done

   BDS: Loading NiRioSrv (NiRioSrv) ... done.

   BDS: Loading bb_libk (bb_libk) ... done.

   BDS: Loading niriozynqk (niriozynqk) ... done.

  Starting systemWebServer: done

  Starting NIAuth: done

  Starting lkads: done

  Starting applicationWebServer: done


  Starting NI-VISA Server...

  NI-VISA Server 5.4 started successfully.

  Interface eth0 - MAC addr: 00:80:2f:15:46:93 - (primary - static)

  Interface eth1 - MAC addr: 00:80:2f:15:46:94 - (static)

compactRio-9068 login:  NI Scan Engine initialized.

Welcome to LabVIEW Real-Time 13.0

0 Kudos
Message 11 of 14

Finally I got the solution. The issue was related to the absence of mountnfs service. CompactRio boots up with runlevel 5. After digging deeper, it was found that '/etc/init.d/' service is not not connected in /etc/rc5.d/ and was not getting executed.

I used following commands to connect it to rc5.d:

# cd /etc/init.d

# update-rc.d start 69 5 .

  Adding system startup for /etc/init.d/

Note: Sequence number '69' is used here as at reboot level 6 (/etc/rc6.d/) the is running at sequence: 31. (standard rule: 100 - 31 = 69)

# ls -rtl /etc/rc5.d -> ../init.d/

After next power boot-up, I could see that my nfs share (defined in /etc/fstab) was mounted without any issue: (shown below)

# mount

rootfs on / type rootfs (rw)

ubi1:rootfs on / type ubifs (rw,relatime)


: on /mnt/iasHome type nfs (rw,relatime,vers=3,rsize=524288,wsize=524288,namlen=255,hard,nolock,proto=tcp,port=2049,timeo=70,retrans=3,sec=sys,local_lock=all,addr=

Thank you BradM and TD for your help on guiding towards right direction.


Message 12 of 14

This saved me a ton of time and worked great thanks so much for sharing!

0 Kudos
Message 13 of 14

Hi jdaming, good to know that it helped you. Thank you.

0 Kudos
Message 14 of 14