Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

measuring small voltage

Hi,

 

I have a USB-6225 and I'm trying to measure the voltage across a current sense resistor with the ai0 differential input. 

 

I created the task in C with the following call 

 

DAQmxCreateAIVoltageChan(taskHandle,"Dev1/ai0","",DAQmx_Val_Diff,-0.2,0.2,DAQmx_Val_Volts,NULL));

 

I used the range -0.2 to 0.2 because that was the smallest input range for this DAQ with 16 bit accuracy.

 

The voltage across the resistor is connected to terminals 1 and 17 in the DAQ.  According to the docs, these are the correct terminals for a differential input to "Dev1/ai0"

 

The actual voltage accross my resistor is approx 0.001 Volt, but the call to DAQmxReadAnalogF64 is returning numbers around 0.123 Volts.

 

What am I doing wrong?

 

Thanks,

Hans

 

 

 

 

 

 

0 Kudos
Message 1 of 2
(2,587 Views)

Hello Hans G,

I have a question about your setup and something I would like you to try.

 

  1. In terms of the resistor across AI0 and AI8. What is the value of the resistor and what current is passing through it? I am asking this because the USB-6225 has ±100 pA of input bias current that could be affecting your measurement.
  2. Could you try the same application, but at full range of -10 to 10 Volts instead. This could be very useful in finding out if this is a problem with your internal amplification or calibration.
  3. Have you tried setting this up in RSE or NRSE modes?

 

Any other information about your application that could be affecting your measurements would be useful in diagnosing this problem.

Regards,
Dan King

0 Kudos
Message 2 of 2
(2,569 Views)