Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Unreliable detection of USB-6210

Go to solution

OK, the problem does not seem to be completely solved after all.

On two out of three computers everything works fine. On the third computer the NI Device Loader service does not start up reliably on boot-up.

If I manually start the service, the DAQ card is detected, and works fine from then on.


NI Device Loader is set to start automatically, and to restart on all failures, but still doesn't start up most of the time.

In the dependencies, I see that this service is dependent on two other services; National Instruments mDNS Service and NI Configuration Manager.


Both these services always start up as they should, but still NI Device Loader doesn't reliably start up.


Any ideas on how to get NI Device Loader to work as it should?


I can manually start the service, but is there any way for my LabVIEW program to start up the service? So then I could get my program try to use the DAQ card, and if it errors out, I could then start up NI Device Loader programatically, and try again.




0 Kudos
Message 11 of 14

Hi Mark,


That is disappointing that it seems to be not working as intended.  I have found there is a way to programmatically start Windows services using LabVIEW.  Follow this KB article on how to do so:


Let me know how it turns out!

Matt S.
Industrial Communications Product Support Engineer
National Instruments
0 Kudos
Message 12 of 14

Hi Matt,


Thanks for the link.

I modified my program to start up the "NI Device Loader" service if it finds that the DAQ card is not installed.

I finally got out to the customer's site yesterday to try it out and found that the computer had suddenly decided to behave itself - "NI Device Loader" was starting up reliably every time I booted up the computer. Sigh...

The only way I could test my program was to stop the service, plug in the DAQ card, and then run my program. But it seemed to work OK - the service started up, the DAQ card was detected, and my program ran fine from then on.


I'm hoping that the original problem has gone away, but if it hasn't, the change I made to my program should get around it.




0 Kudos
Message 13 of 14



I am also facing issues with the USB 6210, the device has been running with software installed however one day the software which we use returned with the "No Hardware Detected" error message despite being connected.


Upon further investigation it was noted that the LED on the 6210 board was not illuminated, this was then plugged into an alternative computer with NIDAQmx installed with the LED illuminating and functioning correctly.


On searching the device manager the 6210 board was listed under NI devices as "USB Firmware Loader" i manager to have this recognised as USB 6210 eventually but the device now says it has not been fully installed, would you have any ideas what i can try?




0 Kudos
Message 14 of 14