Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

USB-6211 Noisy Pressure Transducer Signal

Go to solution



I have a pressure transducer connected to AI 7 & AI 15 ports of my USB 6211.

This setup has been working fine until last week, then something weird happened this week. Now I'm getting a really noisy voltage signal. I have attached a picture of the signal.

When I use a multimeter to check the voltage reading, I get the expected value which is 4.7 volts, but when I try to read the signal from LabVIEW, the signal fluctuates between 0-4.7 V. Although, the noise seems to show some kind of a pattern.


It worked perfectly fine until last week. I have tried connecting the DAQ to different computers, re-wiring the whole setup and even grounding the AI ports with AI GND. I'm running out of ideas on how to fix this issue!!

Please, any help would be very much appreciated.


Thank you!

0 Kudos
Message 1 of 5



I have tried to view this data on an oscilloscope to see if the behavior is also seen there? Also, have you tried to use a different pressure transducer with the DAQ device to see if the problem could be with the transducer? 


I would suggest inputting a sine wave to the DAQ device and see if the data also shows up noisy in LabVIEW. This will help us determine if there could be something wrong with the DAQ device. Another step you could try is to self - calibrate the device in MAX to see if it provides better results for you. 




Shezaan Noorani 

Applications Engineer 

0 Kudos
Message 2 of 5



I don't have an oscilloscope in the lab... so this is not really an option for me.


I have tried using different pressure transducer and self-calibrating the DAQ but the same behavior shows up.

I'll try to input sine wave to the DAQ to see if the device is malfunctioning..



0 Kudos
Message 3 of 5

What happend before it stopped working?


Was there any voltage into it that might damage the unit?


Did the connection with the computer was lost and then reestablished? This being the case something happened during a testing and damaged the device.

0 Kudos
Message 4 of 5
Accepted by topic author yk57

It turns out that it was a grounding problem. My computer is not grounded so, I connected AI GND port to wall outlet and the noise disappeared!

I was able to figure it out because when I use USB 6211 on my laptop on battery mode, the noise was gone.


Problem solved! Thanks everyone for help 😃

0 Kudos
Message 5 of 5