Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

USB-6211 MacOS Setup

Greetings,

 

I am trying to use a USB-6211 with MacOS (Big Sur, 11.4, 64bits). So far, I installed:

 

  • NI MAX 21.0
  • NI VISA 21.0
  • LabView 21 (Community Edition)

 

During the VISA installation, I did go into the Security panel of MacOS in order to allow the driver installation, and I further restarted my computer as prompted. I then followed this link to setup USB communication with the USB-6211:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA03q000000x2wyCAA 

Whose first step redirects to this tutorial:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA03q000000x1qzCAA 

 

I suppose the USB-6211 is an USBTMC Instruments. When I start MAX with the USB-6211 connected to my computer it looks like:

edervieux_0-1636705782293.png

Which may be kind of OK and encouraged me to go to the "Test Communication" section.

Note: since I did not know whether my device was USBTMC or not, I also tried to start the NI-VISA Wizard Config tool, as described here (Section  USB RAW Instruments), but the USB option appeared to be greyed out (the USB-6211 was connected to the computer as in the above screenshot):

edervieux_1-1636705926321.png

 

--

 

Then, following the "Test Communication" instructions, I go to the "Input / Output" section of the VISA Test Panel, and try to communicate. However I got the following error message when pressing the "Write" button:

 

Read Operation
Error

VISA: (Hex 0xBFFF003A) Unable to start operation because setup is invalid (due to attributes being set to an inconsistent state).

 

See screenshot below:

edervieux_2-1636706206124.png

 

I do not know what to do. If someone has any suggestion I would be more than thankful !

 

Note: when using "ls /dev/tty*" I see no difference before and after plugging the USB-6211 in. However, I do see the device appearing and disappearing from the MAX device list as I do so... (I do not know whether the USB-6211 is expected to appear as a regular serial device though, so this may be of little significance). Also note that no LED ever shined up on the USB-6211...

 

--

 

Related topics:

https://forums.ni.com/t5/LabVIEW/macOS-USB-serial/m-p/4163855 

https://forums.ni.com/t5/Multifunction-DAQ/Usb-6211-device-not-recognised-in-Mac-MacOS/td-p/743922 (very old)

 



EDIT:

 

I further installed NI-DAQmx_Base_15.0.0 because why not? After that, whenever I plug the USB-6211 in, its LED blinks slowly (~1Hz, normal operation code) and if I start MAX, I can know see its Vendor, Model, and S/N information:

edervieux_1-1636710009028.png

 

However, when I try to "Query" the device, the "Read" operation fails:

 

edervieux_0-1636709987192.png

Note that in this case, the "Write" operation does not throw the same error message as before. Also note that after I once clicked the "Query" button, the LED on the USB-6211 lights up continuously (error code).

0 Kudos
Message 1 of 2
(241 Views)

First and foremost mistake - USB6211 is a DAQmx device and hence requires DAQmx driver to be installed.

 

6211 is not a Serial device to work with VISA and will not respond to VISA interactions.

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF
0 Kudos
Message 2 of 2
(215 Views)