Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Test panel will not start

I was running nidaqmx 8.7 on winxp ok, then I installed a brand new PCIe-6363.  It required an upgraded nidaqmx driver, so when I installed version 9.0 which came with the card, it installed, but the Measurement and Automation explorer Test Panel feature does not work (no errors, just nothing happens).  When I try and run Test Panels from the command prompt, I get "MFC90.dll not found" type of errors.

 

I have uninstalled/re-installed NI software, xp service pack 3, and visual studio 2008 runtime libraries to no avail.  Copying MFC90.dll and a few others does not seem to work due to different versions of these *90.dll files.....HELP.

 

Any clues?

0 Kudos
Message 1 of 5
(3,399 Views)

Howdy Johnny!

 

It could be possible that the disk you installed from was corrupted.  Try downloading DAQmx 9.1.1 from the web and installing from that.

 

Regards,

Barron
Applications Engineering
National Instruments
0 Kudos
Message 2 of 5
(3,362 Views)

Hi,  johnny9999999

 

Have you solved your problem yet?  I ran into the same case today and found a solution.  You may try the following steps

 

1) go to C:\WINDOWS\system32

2) rename the file named "nidmfpan.exe.manifest" to something like "nidmfpan.exe.manifest.back"

3) try open testpanel on MAX or type in run as "nidmfpan.exe /devid:dev1"

 

Regards,

 

 

Osamu

National Instruments Japan

Message 3 of 5
(3,246 Views)

Thanks, I will try that...other fixes had not worked still to this day...

0 Kudos
Message 4 of 5
(3,232 Views)

Renaming the .manifest file worked for me.

 

I even copied the mfc90*.dll files that where stored in a folder under C:\winnt\winsxs\... to C:\winnt\system32 but that didn't work.

 

Not sure what went wrong with the installation of NIDAQmx 9.2.3.

 

Thanks again for the tip.

 

Ralf

0 Kudos
Message 5 of 5
(2,920 Views)