Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Status code -88705

Hello NI community,


I have recently taken over a project that is already in progress and unfortunately I am very new to using NI devices, so I am looking for some help.

We have a fully operational system on PC-1 where all devices are functioning correctly, and for security purposes we need to have the same system installed onto PC-2.

All necessary software has been installed onto PC-2 as per the supplier user guides, however 3 NI devices are coming up with a "not present" status.

The NI software versions installed on PC-2 (attached) are either the same version (or a more updated version) in comparison to PC-1.

These devices are all connected to PC-2 via USB3.0 (through a USB hub or directly into a USB3.0 port on PC-2), where the same error occurs in both scenarios.

Both PC-1 and PC-2 are running on Windows 10.


I've tried searching around on the forums and came across this thread:


But it seems that the solution provided by AK2DM does not solve my problem.

I tried to look around on the NI website, but I do not believe there are updated drivers that can be downloaded for these devices.


If anyone could please provide some assistance, that would be greatly appreciated.

Thank you very much.

0 Kudos
Message 1 of 2

NI's guide for troubleshooting:

  1. Error -88705 or 80040383 with DAQmx or GPIB Device in NI-MAX - NI
  2. NI DAQ Device or Module Does Not Appear in LabVIEW And/Or MAX - NI


It looks like something went awry with the DAQmx driver installation or driver services starting up. I would check device manager to see if these devices has NI driver associated with them, if NI device loader service is running, and whether there is any error about starting NI driver/services in the Windows event log.

0 Kudos
Message 2 of 2