Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

NIMAX not detecting NI devices

Go to solution

I have got a problem with NIMAX which is not detecting any of the two NI devices connected to the computer anymore. It was working fine until a recent windows update with some seemingly unrelated patches (see figure).

Windows device manager can see both devices, i.e. cDAQ-9178 and NI-6009 (see figure) but they are both reported as "not present" in NIMAX.

We have tried to restart computer and devices, meaning 10 second power cuts, several times. Then used "repair" option of DAQmx driver with no change. Then uninstalled all NI software, restarted and re-installed LabView RTE, VISA and DAQmx again. Then upgrading them through NI update service to the last versions.

Both device are connected directly to the USB ports just as a separate 4 port serial device which IS detected also by NIMAX.

Computer: Dell 7490, Win10 pro
LabView RTE: 2014 Sp1 f11
NI VISA Runtime: 14.0.1
DAQmx: 14.0.0

What am I missing? Is there anything else I could try before sending all hardware back from a remote station in Greece.



0 Kudos
Message 1 of 4
Accepted by topic author user_4342726352435

Similar issue here yesterday again after updates- 3 systems failed to detect hardware.

In Services, try setting the NI device loader to Automatic Delayed Start and reboot.

It may take a minute or two for the service to start. Then go into Max and deleted 'dead' devices and rename found ones accordingly.



"It’s the questions that drive us.”
Message 2 of 4

Thank you for the tip. It worked perfectly. Up and running again. Smiley Very Happy

0 Kudos
Message 3 of 4

Glad to be of 'Service" 🙂



"It’s the questions that drive us.”
0 Kudos
Message 4 of 4