Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Occasional -10240 errors from NIDAQ.

I am developing software that utilizes the Traditional NI-DAQ 7.0 functions for Analog Output and Analog Input. I have found that occasionally, I will get NI-DAQ -10240 errors while my software is running which causes me to restart the software - then everything is fine. I am running CVI 7.0, Test Stand 3.0, and NI-DAQ 7.0. The errors occur in functions that I created in CVI and through DLLs using Test Stand.
0 Kudos
Message 1 of 6
(3,136 Views)
Greetings,

Have you been able to determine which Traditional NI-DAQ functions are returning this error? Is this behavior reproducible, or does it happen at seemingly random times? Your post leads me to believe that you are calling NI-DAQ functions in a CVI DLL from TestStand. Can you run the same NI-DAQ code in the CVI development environment without receiving this error?

Spencer S.
0 Kudos
Message 2 of 6
(3,135 Views)
Spencer,
I get this error for every call to a Traditional NI-DAQ function in my sequence. The first function I call in my sequence is AO_Configure, which returns the -10240 error, then every NI-DAQ functional call after that in the sequence returns the same error. The other functions that I am using is AO_VWrite, DAQ_Clear, AI_Configure, SCAN_Setup, SCAN_Start, DAQ_Check, SCAN_Demux, and DAQ_VScale. If I shutdown my software start it back up, the error seems to go away. I have not been able to consistantly reproduce the behavior. I have not been able to successfully reproduce the error when I run the code in the development environment, but the error isn't very repeatable.
Thank you for your comtinued help
0 Kudos
Message 3 of 6
(3,135 Views)
Thanks for the additional information. My first suggestion would be to install the most recent version of the NI-DAQ driver. Below, I have included a link to the location where NI-DAQ 7.2 can be downloaded:

NI-DAQ Version 7.2 for Windows 2000/NT/XP

Spencer S.
0 Kudos
Message 4 of 6
(3,135 Views)
Hi,

I am experiencing similar problems and have tried various NI-DAQ drivers (well, 7.4.0 and 7.4.1) but that hasn't remedied things - I just wondered if you had managed to fix this issue?

Thanks
0 Kudos
Message 5 of 6
(2,930 Views)
acrmartin,

This issue has been documented in knowledge base articles on our website, but the solution varies depending upon the hardware in use.  What NI hardware and programming environments are you using?

Essentially, this error occurs when a function being called is not available in the dll file.  Can you isolate the particular function being called when this error occurs?  The most likely solution is a re-install of the drivers.  In some cases it is necessary to manually select portions of the driver that are normally only installed when certain programming environments are installed.  For example, if CVI is not installed on your system, certain driver functionality may not be installed by default.

The following link is to a knowledge base article that pertains to a different driver.  However, the steps outlined in it are similar to what may be necessary to solve your problem.  Click this link to check it out:
http://digital.ni.com/public.nsf/websearch/B53F3D5ADCFF287B86256869006EF6A9?OpenDocument

If this doesn't work out, post the answers to my questions and we'll troubleshoot from there.  Thanks!


Elijah Kerry
Chief Product Manager, Software Platform
_______________________________________________
Follow my Software Engineering for LabVIEW Blog
0 Kudos
Message 6 of 6
(2,904 Views)