Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Deprecation warning for nidaqmx using Python

Hi,

 

I see the following warning when using nidaqmx:

DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated since Python 3.3, and in 3.9 it will stop working

 

The issue on Github:

https://github.com/ni/nidaqmx-python/issues/73

 

Hope someone knows how this can be fixed, or if NI are planing to - 3.9 is right around the corner 😉

 

BR Jesper

0 Kudos
Message 1 of 2
(1,517 Views)

Hi Jesper. 

As far as I could see there is as of today no official plans to update nidaqmx beyond Python 3.4. 

However, it's not beyond reason that it's in the works due to Python's popularity.  

I would suggest bringing this to NI R&D's attention in case it's not actually been picked up on yet. I'd suggest posing a suggestion on https://forums.ni.com/t5/Data-Acquisition-Idea-Exchange/idb-p/daqideas  
This board is continuously monitored by NI R&D engineers. 


Best of luck. 
Andreas

There are only two ways to tell somebody thanks: Kudos and Marked Solutions

Unofficial Forum Rules and Guidelines
Message 2 of 2
(1,449 Views)