Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

6008 not recognized by Device Manager, listed as Unknown USB device.

I am left with the Device manager not recognizing my 6008's.  This is all on Runtime.   14.0.1 SP 1F


Hoping someone has run across this issue.


Using the same installer on multiple computers (20 plus), no problems.


Here are some things I have tried.

  1. Uninstalled and re-installed.  Uninstalled and reinstalled from a separate download of the installer.  Reboots all over.
  2. Tried to directly add driver, but target computer doesn't have "C:\Windows\System32\drivers\nixfmrrkw.sys"   Not sure if this would work anyhow.  I'm guessing if this did not install, there must be a larger underlying issue.


Verfied the following.

  • No other USB devices
  • Admin log in
  • Application runs, but no DAQ. So Runtime works.


Has anyone used the registry to verify a DAQmx Runtime install?

  • My working computer only shows one registry entry for DAQmx, the path.   There doesn't seem to be a DAQmx runtime registry entry on my working PC.

Any hints or experiences welcome.


0 Kudos
Message 1 of 6

Hi RainbowShadow,


Does the device show up in MAX under "Devices and Interfaces" and does NI-DAQmx show up under "Software"? If not, it may be associating the device with the wrong driver. This document describes how to fix incorrect driver associations but I'm not exactly sure how you would remedy this in your installer.


If that doesn't bear any fruit, you can also generate a log from the installer using the /log switch as described here. You may also find useful debug information by looking at the NI Installation Log files that are automatically generated when you install NI software. This document describes the locations of those files.

0 Kudos
Message 2 of 6

Thanks for the reply.


The device shows up in Device Manager in the USB branch, so there is no "Data Acquisition Devices" branch.    This may be a clue as to what is happening.


Unfortunately we don't distribute MAX in our installer.   I was debating sending a MAX installer, with an updated RTE installer.  I think having MAX installed would only get me information on the software installed, as the 6008 is not visible.  I'm guessing it would not see the devices if windows can't.   Is that a correct assumption, that if windows can't see the devices, MAX can't? 


Another Note:

  • I have looked at the Windows Event Log, and it doesn't show any errors for the installation.


0 Kudos
Message 3 of 6

In general, if Windows can't see the device, MAX can't. I have seen situations where the device was recognized improperly by Device Manager and subsequently showed up incorrectly in MAX, but typically if Windows is misidentifying the device, MAX will also fail to recognize/display it.


You can also confirm the DAQmx installation by going to the Programs and Features application in the control panel, double-clicking the "National Instruments Software" listing and verifying that DAQmx is listed in the resulting window. In general, as long as DAQmx is installed and the device is associated with the correct driver, it should be accessible in LabVIEW applications. 


if you right-click the device in Device Manager and select "Driver Properties" from the context menu and then "Driver Details" in the resulting window, does it show the device is associated with ausbtmc.sys? The device being listed under USB devices rather than USB Test and Measurement devices does align with the possibility that it's incorrectly associated with the driver.


Are there any glaring differences between the problematic PC and the working ones? Is this the same version of the installer that worked previously or a new revision?

0 Kudos
Message 4 of 6

Hi Andrew,


Some quick answers

  • Yes DAQmx is there. 
  • Device Manager details says that no driver is associated with the unknown USB device.
  • This installer has been downloaded by over 20, probably near 40, users.  This includes Win7,8,10, and European and Asian systems.  I had this troublesome system re-download to make sure there was not some sort of download corruption.  Thsi install is Win 7, same as our lab and dev PC's.

I am trying a reinstall, and manual adding the nixfmrrkw.sys file to system32\drivers, as this is the associated file that our working system Device Manager properties are pointed to as the driver.   This file was not added by the installer on this troublesome install, and I am verifying this file is on some of the other installs, FWIW.   I think that "just one file" will probably not resolve the issue, but wanted to try anyhow.




0 Kudos
Message 5 of 6

In that case, if the re-install and manual copy doesn't work, your best bet is probably to fully uninstall the application and then re-install and generate a log using the /log switch. The log should give some indication as to why that particular file is failing to install to the correct location.

0 Kudos
Message 6 of 6