Motion Control and Motor Drives

Showing results for 
Search instead for 
Did you mean: 

Coordinate space in LabVIEW

Go to solution

Coordinate space in LabVIEW



I am using the Getting Started with NI 951x C Series Modules and LabVIEW tutorial and I can't seem to get it to work. I followed it step by step and when I clicked execute on the front panel, I got the following error. Error code: 70028


Straight-Line Move when Setting Position[] on Test Section.<ERR>
The resource is not large enough to perform the specified operation.

<b>Complete call chain:</b>
Straight line move


All I did was create a 3 axis coordinate space and the tutorial calls for two. I tried removing one axis and only using two but that didn't work. My block diagram looks the same as the one in the example except I seem to only have ONE coordinate in my system (notice the bottom left wire connected to position[] only has one coordinate box instead of two like the example). I've tried starting over and re-creating the coordinate axis and the VI with the same result. Am I missing something? It seems as though my coordinate system is showing up as 1x0 array instead of a 1x3 array or something? 


I tried rebooting the cRIO and starting an entirely new project, basically starting from step 1 excluding the installing of software on the cRIO. Please let me know if you have any advice or have had any of the same problems. Thanks

0 Kudos
Message 1 of 2
Accepted by topic author cforem5
08-27-2015 04:09 PM

Re: Coordinate space in LabVIEW

Hi cforem5,

Are you able to run any of the shipping examples that came with SoftMotion?  Running these will let us know if it is an issue with your hardware configuration or if it is something with the LabVIEW code.  

Kira T
0 Kudos
Message 2 of 2