Measurement Studio for .NET Languages

Showing results for 
Search instead for 
Did you mean: 

could not load file or assembly 'NationalInstruments.UI.Styles3D.dll'

Go to solution

could not load file or assembly 'NationalInstruments.UI.Styles3D.dll'


I am getting the following error:

Could not load file or assemble 'NationalInstruments.UI.Styles3D.dll' or one of its dependencies.

In my development machine, programs runs ok. W&, VS2010 and MS 2010.

I get the error in the target machine, WXP, service pack 2.

The foilder containing the executable has the following files:

NationalInstruments.Common.dll (version

NationalInstruments.UI.dll (version

NationalInstruments.UI.Design.dll (version

NationalInstruments.UI.Styles3D.dll (version

NationalInstruments.UI.WindowsFroms.dll (version

NationalInstruments.VisaNS.dll (version


The programs was running ok, I just added a new label to the application, installed it again and then the error comes.



Alberto J.

0 Kudos
Message 1 of 4

Re: could not load file or assembly 'NationalInstruments.UI.Styles3D.dll'

Hi AlbertJ,


Did you include the DLLs that are in the programs folder with the original installer, or did you just copy them over?  If you included them, did you include them individually or did you use the merge modules?


I would try adding the appropriate merge modules to the installer, re-install, and see if you still get the error.  There is a Measurement Studio help topic called Measurement Studio .NET Merge Modules that can help you determine which merge modules you need to add.  There is also a Measurement Studio help topic called How to: Add Merge Modules to a Deployment Project if you need help adding them.


Let me know what you find.




Brandon V.

Applications Engineering

National Instruments

0 Kudos
Message 2 of 4
Accepted by topic author AlbertJ
08-27-2015 04:09 PM

Re: could not load file or assembly 'NationalInstruments.UI.Styles3D.dll'

I ran into the same issue and discovered that the NationalInstruments.UI.Styles3D.dll depends on the Visual C++ 2010 Runtime which is installed with Visual Studio.  You can download the runtime redistributable installer to deploy on the target machines.  It is available here:

Message 3 of 4

Re: could not load file or assembly 'NationalInstruments.UI.Styles3D.dll'

Thank you very much JPoore for this information

0 Kudos
Message 4 of 4