Machine Vision

Showing results for 
Search instead for 
Did you mean: 

error 0xBFF6901B



I would like to work with a digital camera Progres SpeedXT Core 5 under labview. I have connected it and I have started NI MAX. After  pushing the button Grab I have received an error 0xBFF6901B. I am sending a screenshot of my error. I have stopped the firewall and the antivirus program but I still have the same error. I talk with the engineer from the company (Jenoptik) selling this camera but he didn't resolve the problem. Could you please help me?



0 Kudos
Message 1 of 13

Hello tiho,


As you can in the picture, that's a Timeout problem.If you search for "Timeout" in Machive Vision board you find suggestions for solution.



As a simple solution, you can set the timeout period much higher. Default valus is 5000 ms. 


0 Kudos
Message 2 of 13

Hello tiho, there is also another possible solitions for this problem. Let me know if setting timeout value not helps.

0 Kudos
Message 3 of 13



Unfortunately setting the timout didn't help. Could you please give me another solution?

0 Kudos
Message 4 of 13

Hello tiho, if i'm not mistaken your camera is a USB camera.


- What kind of USB-cable are you using? How long is the cable? The connection between the computer and the camera are quite important if you use USB-Camera.

- I see on your screenshot that you have installed IDS uEye. Had you problems with uEye, too?

0 Kudos
Message 5 of 13

I have no problem with ueye camera. I am using mini USB cable 2 meters long. 

0 Kudos
Message 6 of 13

Hello tiho,

I asked about USB-Cable, because sometimes a good USB-Cable makes the difference.


Do you have this problem just at MAX?


NI Vision with USB2-cameras use DirectShow. With MAX you can't change all the setting if you use USB2-Camera over DirectShow.


Some cameras has a setting: "Pixel clock". (for example IDS uEye cameras have it). It can help to solving the "Timeout"-Problem if you decrease this value.


You need an application like AMCap if you want to chance this setting for your camera. Or, in your case, i can see that you already installed IDS uEye. There is a sample program in IDS uEye package "uEye_DirectShow_Demo.exe". You can find this under "Program Files -> IDS -> uEye -> Samples"


- After you run this program you choose camera under "Select active video source"

- Then button "Pin Properties"

- Disable Auto exposure if it is set

- Decrease the value "Pixel clock" then OK


Try with these new setting. If MAX again gives "Timeout", you can do the changing the pixel clock again.


Download All
0 Kudos
Message 7 of 13



I found uEye_DirectShow_Demo.exe and I have started it as you explained but connecting my uEye camera. With the other camera it was not possible to start the application. A have set the pixel clock but the error is the same.



0 Kudos
Message 8 of 13

Hello tiho,


You mean that you connected your uEye camera? Did i understand correctly? Changing pixel clock of uEye camera don't help you.


"With the other camera it was not possible to start the application." That is important. I think we are one step closer to solution:

There can be two problems:

- USB Connection problem -> Which USB speed mode? It must be "Fullspeed USB" on this port. Can you check if it is low speed? Or try an anotther USB-port

- DirectShow service for this camera is not correct installed.

0 Kudos
Message 9 of 13



How to check the speed of my USB porf? I have connected the camera on a diffrent USB port but the error is the same. 

With the other camera it was  not possible to start the application. I have started the application only with uEhe camera. 

0 Kudos
Message 10 of 13