Showing results for 
Search instead for 
Did you mean: 

manage configurations possible bug in CVI2010

In LW/CVI  2010 version 10.0.1 (419) I found that the way to manage configuration does not work fine.

What I mean is:

If I go to Menu > Build > Target Settings... and set there for example DLL file path, it remembers the settings and put the output DLL to the pointed place.

If I go to Menu > Build > Configuration > Manage Configurations... > then press Edit... button for a chosen configuration > in new dialog press Target Settings... button and and set the DLL file path now > press Ok > Press Done > press Done, it WILL NOT remember the settings and put the DLL to the original path not the one I set.

0 Kudos
Message 1 of 7



I hope you are doing well today!  Thank you for bringing this to our attention.  However, I attempted to reproduce what you are seeing, and I have found that when I set the file path for a DLL by following each of your instructions, it creates the DLL in the correct directory.  Just to verify your steps, are you changing the DLL File parameter in the settings?


When you go to the Manage Configurations window and edit a particular build configuration (according to your second path above), make sure that when you have saved this configuration and are attempting to build that you have set that same configuration in the build settings.  This can be done by going to Build»Configuration.  If you are still not seeing it build the DLL in the correct location, could you post screenshots of your configuration settings following each of the paths you mentioned in your post?  Thanks, ZVS!  Have a great day!

Taylor G.
Product Support Engineer
National Instruments
0 Kudos
Message 2 of 7
I t
0 Kudos
Message 3 of 7

I tried again and it work fine if I modify settings of the current configuration but not for the one that is not set as current.

To be more specific.

1. I have an additional configuration called "Debug Simulation". It is a debug configuration with some additional macros defined, no more.

2. I set the "DLL file" to identical for all configurations.

3. I set the current configuration to release and build it Menu > Build > Create DLL (I use short name for this loooong menu item Smiley Wink). It works fine.

4. Now I do not change the configuration but go to Menu > Build > Configuration > Manage configurations.

5. Choose "Debug Simulation" one and press "Edit" button. Now press "Target Settings" and point "Dll file" to another folder.

6. Close all, pressing "Ok", "Done", "Done".

7. Now go to Menu > Build > Configuration > choose "Debug Simulation" one.

8. Now choose Menu > Build > Create DLL.

9. When the build is finished (not a full rebuild, only a couple of files recompiled) it shows in a pop up window that the DLL is placed in the prewious location. And it is there for sure.

Some other notes.

1. This bug seems to appear only for a customer configuration, it works fine with Release or Debug standard configuration.

2. I have 6 projects in the solution and it works the same way for any oif them (did not try the project with executable though).

And even more. I noticed that sometimes (I think when I created "Debug Simulation" configuration) I was not able to choose different Exports options (button "Change..." in a target settings screen). Whatever option from the list I choose ("Include file sympols", "Symbols marked for export" and so on), it always reset to the one (do not remember which one exactly now) option. When I close dialogs and then go to edit configurations, I was able to set the correct option there.

And the final thing. There is a lack of another "Batch Build..." menu item. I mean now I need to set 6 marks to different configurations when I want to build debug versions of all projects and then choose another 6 marks if I want 6 releases. I cannot build all at onece since I put the output files (DLL and EXE) at the same location so either debug versions or release may exists at the same time. So I would be happy to have at least two options for "Batch Build..." so I could marked needed configurations in both and choose only which one I want to build.

Hope not to much words. Smiley Happy

0 Kudos
Message 4 of 7

I ran a bit more tests and looks like if you edit a customer not active configuration, it just does not remember the target settings when you press Ok

0 Kudos
Message 5 of 7



Thank you for the extra clarification.  This was reported to R&D (#322458) for further investigation.  They will look into this behavior.  For now, the best workaround would be to manage your configuration settings by going to Build»Target Settings.  


Thanks again for bringing this to our attention, ZVS, and I apologize for any inconvenience.  Have a great day!

Taylor G.
Product Support Engineer
National Instruments
0 Kudos
Message 6 of 7

Thank you, Taylor for attention.


Using Build»Target Settings is what I do and that is why I do not think the problem is too important.

0 Kudos
Message 7 of 7