LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

example simpftp does not compile

Solved!
Go to solution

Hi,

 

I am developing an application in which I use the ftp function InetFTPAutoSend.  When I compiled I get unresolved symbol error:

  error: Undefined symbol '_InetFTPAutoSend@24' referenced in "...XPSWrapper.obj".  

I decided to check if it was a problem in my project by compiling the example simpftp provided with labwindows CVI, in both release and debug I get the same problem of undefined symbol:

Build Status (simpftp.prj - Release)
 simpftp.c
 Link simpftp.exe
  error: Undefined symbol '_InetFTPAutoRetrieve@24' referenced in "c:\Users\Public\Documents\National Instruments\CVI2015\samples\internet\simpftp\cvibuild.simpftp\Release\simpftp.obj".  
  error: Undefined symbol '_InetFTPAutoSend@24' referenced in "c:\Users\Public\Documents\National Instruments\CVI2015\samples\internet\simpftp\cvibuild.simpftp\Release\simpftp.obj".  
  error: Undefined symbol '_InetGetErrorMessage@4' referenced in "c:\Users\Public\Documents\National Instruments\CVI2015\samples\internet\simpftp\cvibuild.simpftp\Release\simpftp.obj".  
Build failed.

I could not find anything that worked to solve this issu on this forum.  Is anyone else using ftp function and managed to get it to work?

 

Thanks in advance to those who will take time to read and those who will take time to answer.

0 Kudos
Message 1 of 4
(3,780 Views)
Solution
Accepted by topic author Rémy.Lassalle-Balier

Hello Rémy,

 

You could have LabWindows/CVI Base Package that doesn't include Internet Library. See here.

To check which package you have install you can click on Help->About LabWindows/CVI. In the splashscreen you can see in the right-bottom corner which package you have. Alternatively you can check in NI License Manager (Start->National Instruments->NI License Manager) which license is activated.

 

Constantin.

0 Kudos
Message 2 of 4
(3,762 Views)

Hi,

 

Ok problem solved, I symply do not have the full developper suit while the cvintwrk library is available from the full developper suit and higher licenses.

0 Kudos
Message 3 of 4
(3,761 Views)

Hello, I'm not using FTP in my applications but I tried compiling and running the example you mentioned and had no problems in debug mode in both 32 and 64 bit configuration.

My situation is: Win7 Pro SP1 64bit, using CVI 2015, release 15.0.0 (408)

 

(Gosh! I opened the message before the response from Constantin, and didn't update the window before posting Smiley Sad ).



Proud to use LW/CVI from 3.1 on.

My contributions to the Developer Community
________________________________________
If I have helped you, why not giving me a kudos?
0 Kudos
Message 4 of 4
(3,753 Views)