LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

driver dl1540

Solved!
Go to solution

Does anyone have a complete Labwindows/CVI driver for a Yokogawa oscilloscope DL1540?

On the the drivers page I found a function panel  (ykdl15xx.fp) and the header file but what I think what's missing is the source 'ykdl15xx.c' because my program gives project link errors like: Undefined symbol in 'ykdl15xx_Initialize' referenced in "my_program.c"

0 Kudos
Message 1 of 22
(3,719 Views)

the driver maybe is right,check your program.

0 Kudos
Message 2 of 22
(3,716 Views)

Is it so that programs do not always need the C-source corresponding to the -.fp and -.h file?

0 Kudos
Message 3 of 22
(3,710 Views)

Dear FonzB,

 

did you follow the following tutorial tutorial

 

Please notice that you also need the Labview 8.0 Run Time Engine.

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 4 of 22
(3,697 Views)

Hi Martijn,

 

I've just read the tutorial and checked the run-time engine of Labview: 10.0.1 and the CVI run-time engine is 2010.

I added the -.fp file to the project as written in the tutorial and also added the -.lib.

The files are installed in: C:\VXIPNP\WinNT\ykdl15xx\ykdl15xx.fp

                                    C:\VXIPNP\WinNT\inculde\ykdl15xx.h

                                    C:\VXIPNP\WinNT\Lib\Msc\ykdl15xx.lib

                                    C:\VXIPNP\WinNT\Bin\ykdl15xx.dll

 But still my application gives this Project link error : Undefined symbol 'ykdl15xx_initialize' referenced in "my_program.c"

 

Shall I reinstall the driver in an other directory like C:\Program Files\IVI Foundation\IVI\Drivers and ...IVI\Include ?

 

 

0 Kudos
Message 5 of 22
(3,695 Views)

Hi FonzB,

 

the download page from the instrument driver states that Labview Runtime 8.0 is needed, so please make sure you have the correct one.

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 6 of 22
(3,690 Views)

Hi Martijn,

 

After downloading Labview 8.0 the installer tells me that the Run time engine won't be installed because "a higher version of this product is already on your computer"

 

MAX tells me that I have: LabVIEW 7.0; 7.1; 8.0.1; 8.2.1; 8.5.1; 8.6.1; 9.0.1; and 10.0.1.

Do I have to uninstall one of them?

 

BR, FonzB

0 Kudos
Message 7 of 22
(3,688 Views)

Dear FonzB,

 

everything looks OK, those are the correct folders and Labview Run TIme 8.0.1 should work for you. Can you create a small example so I can see if I can reproduce the error you are seeing? Which version of CVI are you using?

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 8 of 22
(3,668 Views)

Dear FonzB,

 

Thank you for your code (through private message). Strangely enough the code runs without any problem on my machine. Can you specifically include (checkmark) ykdl15xx.h through build => insert include statements.

Further more we can check the environment variables; please right click my computer, chose properties and go to the advanced tab. Here you can check the environment variables; under path do you have; C:\VXIPNP\WinNT\Bin;C:\VXIPNP\WinNT\Bin\; and do you have the variable VXIPNP referring to the right directory?

 

Else we have to remove the instrument driver and try reinstalling, before installing the driver we can try to repair CVI.

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
Download All
0 Kudos
Message 9 of 22
(3,663 Views)

Hi Martijn,

 

Through Build=>Insert include statements=> the header file can not be found!

I added 'C:\VXIPNP\WinNT\Bin' to the path, 'C:\VXIPNP\WinNT\Bin\' was allready there.

The following system variables that may be important are there:

 

NIIVIPATH: C:\Program files\IVI Foundation\IVI\

NIVXIPATH: C:\NIVXI

VXIPATH: C:\VXIPNP\

 

The VXI system is no longer connected and the pci-mxi2 card is removed from the pc.

 

Best regards,

FonsB

 

0 Kudos
Message 10 of 22
(3,657 Views)