LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx NICAIU.DLL version error

Hi gang,

I'm debugging a DAQmx application I just updated to read a pressure sensor (load cell) with
an NI-9219.  I've used this code successfully a few years ago, but now it's no
longer working.  I'm getting a run-time popup error message about a DLL
(NICAIU.DLL) being the wrong version (see attached JPEG) but
I just installed DAQmx 15.1.1 and DeviceDrivers Feb2016 which are the latest
available and I still get this error.   My code is based upon a CVI example from

a few years ago for acquiring thermocouple readings

 

Thanks for any ideas on how to fix (or debug further) my problem,

 

Erik

 

 /*********************************************************************
*
* CVI Example program:
*    ContThrmcplSamps-IntClk.c
*
* Example Category:
*    AI
*
* Description:
*    This example demonstrates how to make continuous, hardware-timed
*    temperature measurement using a thermocouple.
*
.

 

 

0 Kudos
Message 1 of 7
(4,898 Views)

Hi Erik,

 

Which version of CVI are you using? Is it the same version that the code was originally developed in? I attached the readme for both DAQmx 15.1.1 and your Device Driver, please verify that your version of CVI is supported.

 

DAQmx readme: http://www.ni.com/pdf/manuals/374768g.html

Device Driver: file:///C:/Users/whiggins/AppData/Local/Temp/7zOC6979AF9/readme.html

 

Also, after installing both of these did you restart your computer?

 

Thanks,

Will

0 Kudos
Message 2 of 7
(4,835 Views)

Hi Will,

 

thanks for the reply.  I'm running LabWindows 2015 which was listed as "supported" in the DAQmx readme file link you provided.  I couldn't open the 2nd link you provided because it was referencing a file on your local C:\ drive, but I'm assuming the 2016 Device Drivers are compatible with LabWindows 2015.

 

The example code I'm using came from LabWindows samples a couple years ago, so in that regard it is older than the 2015 code I'm using today.  But I did glance at a DAQmx example from the 2015 CVI release and it called the same function DAQmxCreateTask() that is causing my error, so I'm assuming that function should still work.

 

I'm out of ideas, so any further suggestions you might have on how to debug this error would be appreciated.

 

Thanks !

 

Erik

 

0 Kudos
Message 3 of 7
(4,833 Views)

I have exactly the same problem. We would both appreciate if someone can suggest a solution for this.

0 Kudos
Message 4 of 7
(4,712 Views)

I wonder if you may have some old copy of that dll anywhere in the DLL search path so that the one installed with the last DAQmx (which should be in c:\windows\system32) isn't actually used.



Proud to use LW/CVI from 3.1 on.

My contributions to the Developer Community
________________________________________
If I have helped you, why not giving me a kudos?
0 Kudos
Message 5 of 7
(4,699 Views)

Hi all,

 

thanks for the various suggestions.  I was able to solve the problem by updating my DEVELOPMENT machine to the latest DAQmx 15.1.1 f3 version (not just my DEPLOYMENT machine).

 

Hope that helps others who run into this issue,

 

Erik

 

0 Kudos
Message 6 of 7
(4,695 Views)

Ah good: having the same framework on both machines is always a good practice! Smiley Wink

 

If you had told us this detail on your first post you'd have saved yourself a 10-days headache...



Proud to use LW/CVI from 3.1 on.

My contributions to the Developer Community
________________________________________
If I have helped you, why not giving me a kudos?
0 Kudos
Message 7 of 7
(4,682 Views)