Showing results for 
Search instead for 
Did you mean: 

Cannot Uninstall NI Software

Hello All,


I have been searching the forum and cannot find a solution to my problem, though I have tried following many of the suggestions given in the past. 


On my Windows 8.1 64 bit machine I originally installed The National Instruments 2013 Software Suite.  Being the new guy at work, I was later told I should have the newer 2014 Suite installed.  I then had both the 2013 and 2014 Suite installed.


Later I was told that the 2015 Suite was available and that I should uninstall all older NI software before installing the 2015 Suite.  After uninstalling the older NI software, I performed a registry cleanup using CC Cleaner and then deleted the remaining NI folders within both the "program files" folders.


After a reboot, I downloaded the 2015 Suite from my company's FTP server and proceeded to install.  The files appeared to corrupted somehow as the installation threw some errors.  I later installed again directly from the NI DVDs. 


Now that the installation is complete, NI MAX fails to open and  gives an error related to "mxrmcfg.dll".  At this point, I would like to do a clean uninstall of all NI software and start fresh from the DVDs, however I cannot find any way to uninstall the software.  NI Software is not listed under Add/ Remove Programs, nor are there any uninstall files to be found anywhere relating to NI Software.  


Thanks in advance for your help,




0 Kudos
Message 1 of 5

Hi Aaron,


It's possible that the registry cleanup removed some important keys. That could explain why your software isn't showing up in your Programs and Features to remove. As long as you didn't delete it, you should still be able to run the uninstaller from < National Instruments/Shared/NIUninstaller > directory in your program files.


That being said, there's no guarantee that the uninstaller will work properly with so many files potentially missing. A force reinstall should make sure all of the files are actually replaced, but this doesn't work with suited installers - so you would need to force reinstall every package that is corrupted.


The easiest thing to do would be go back to a restore point and start from scratch.


If you can't get this resolved, call in at 866-ASK-MYNI and create a service request. You should try the above steps first considering that's what they'll have you try when you call in.
0 Kudos
Message 2 of 5



I am experiencing the same issue. My initial problem was that the daqassistant block was not loading the myDaq and would get stuck on "please wait... configuring system". In order to solve this, I decided to reinstall Labview and go from labview 2016 to 2018. However, after reinstalling the new labview and the mydaq drivers, the daqassistant block was not even showing up. So I decided to uninstall the labview as well as deleting all the folders from the computers and the registry keys to ensure that I get a fresh install.


This time, after reinstalling the program, when I click on the icon, nothing happens. I am getting the same error when trying to open NI MAX, and I am not able to uninstall the program from add or remove since the "NIUninstaller" folder is missing from my installation directory. I appreciate your help on this matter since I am in a rush to get this to work.

0 Kudos
Message 3 of 5

Hi there, I have a problem like this. I want to reinstall a labview file. When i doing the installation, an error like the picture shown prompt out. I try to uninstall everything about national instruments and reinstall it but before this, i have already delete all the related file in C drive, program files. And the NI icon is not appear in the control panel. What should i do ? Please help. Thanks !!

0 Kudos
Message 4 of 5

Hi Baoxuan,


Here is a article regarding force reinstall of non-working NI Software

Also, This is a pretty old thread. To get better visibility I would suggest creating a new thread.


0 Kudos
Message 5 of 5