Showing results for 
Search instead for 
Did you mean: 

unusual text+picture ring behavior

I have a text+picture ring control that is displaying unusual behavior (the file is attached below, LV8.2).  When I edit the control itself (.ctl file) the behavior is as expected--that is, there is a picture for every value, and 2/3 also have text associated with them.  The large colored region for the text is on purpose: another control (a simple boolean button) will sit on top of this control's text area.

The problem occurs when I insert this control into any VI.  The default value (1), which shows a red "X" picture appears normal, but when you change the indicator to either of the other two values, the associated pictures are not visible.  Can anyone shed some light on why this is happening?

Message Edited by Yuri33 on 01-31-2008 09:43 PM
0 Kudos
Message 1 of 4
Weird. I can see the same behavior.

Just to see something I tried to create the control from scratch. I didn't go all the way that you did, but what I had done so far seemed to work fine without graphical glitches. You may want to re-create the control step-by-step and see where it starts going weird on you.

Attached is the work-in-progress for the version that I had, for what it's worth.
0 Kudos
Message 2 of 4
That is odd.  When I inserted it, I could see the caution, but not the other two.  However, I could see corners of the X and check mark to the left side of their space, indicating that maybe the image is getting moved under the red boolean area.  I don't know how or why that could be, but maybe somebody else can do something with it.
Also, I just did some more playing around with it, and every time I put the control on a front panel, the missing pieces would have moved around slightly in the right space.
0 Kudos
Message 3 of 4

Hi Yuri33,

I also saw the same behavior with your control. I have been playing around with it and I'm not sure why this is happening. When I insert this control into a VI, I see the check mark but I only see part of the other two images. If I move the red control box around (re-size it), I can see the graphics. It seems as though they are being placed in random parts of the VI and are being covered by other objects. Have you tried to re-do the control? This control could have goten corrupted somehow. Also, where did you get the images from and what type of images are they? Maybe if you post the images, I can try to re-create the control from scratch and see if I get the same problem.


National Instruments
Applications Engineer
0 Kudos
Message 4 of 4