Showing results for 
Search instead for 
Did you mean: 

unable to connect network stream

unable to connect network stream



i have a PXI-8196 as the RT System, and then my host and I'm trying to create a network stream between them.


When I run the RT System up, then run first the RT vi and then the Host vi and connect, there is no problem. The problem comes when I stop the vi's: if then I run again both vi's, the host vi is unable to connect again with the RT vi, as the system returns me the error -314004 when the host vi tries to create the endpoint...  If I then shut the PXI system down and run it up again, it works...


Thanks in advance for the answer!

Message 1 of 3

Re: unable to connect network stream

Try te Simple Messaging Reference Library.  Setting up streaming is fairly easy with it.

Machine Vision, Robotics, Embedded Systems, Surveillance - Custom Imaging Solutions
0 Kudos
Message 2 of 3

Re: unable to connect network stream

"It's all in the wrist" (V White).  You need to decide who is "hosting" the Network Stream (in my case, it's the PXI), and which direction you are streaming (I actually have 4 streams, one PC -> PXI and three PXI -> PC).  The key step is that you need to be sure that the PXI (the system running the Network Stream "engine") is running first.


Note that the error you saw, -314004, (probably) means that the PXI is not, in fact, "listening" for the Host to make a connection.  If you suspect there's a "race" condition (you accidently start the Host first), you can simply say "Oh, that error means I need to wait 10 seconds for the PXI to get ready, then try again".


If all else fails, you can get the PXI to restart itself, ensuring a clean system.

0 Kudos
Message 3 of 3