Showing results for 
Search instead for 
Did you mean: 

run-time error R6025 exiting Labview

After I modify a VI and/or Project, I exit from labview by clicking on file->exit. It will generate a R6025 run-time error. If I just open and close labview, this will not occur.
I am running Labview 8.0.1 on windows XP.
0 Kudos
Message 1 of 10

Good afternoon,


This is indeed a strange error!  I have found a few records of it occurring, and it looks like a couple of things might fix the issue.


1)  If you are using an anti-virus software (such as Norton), disable the “script blocking” feature of Norton

2)  Check to see if you have old versions of the runtime engine installed – go to add/remove programs and look for old versions, then go to “National Instruments” and click “change” – look for versions here too that you might not need.


You might want to try these things before trying a reinstall of LabVIEW, though that might fix the problem as well.  Hopefully this helps, please let me know how it goes-

Travis M
National Instruments
0 Kudos
Message 2 of 10
The Norton Anti-Virus is not an option. The company has locked down the configuration of the Norton Antivirus.
I had uninstall Labview completely before installing 8.0.
Removing it Labview run-time 7.0 and 7.1.1 is not an option. There are several programs dependent on it. One of the modules I need is Ni-Serial 3.0.
0 Kudos
Message 3 of 10



Sorry to hear that the Norton configuration is locked down, because we have about half a dozen instances of this error occurring and all but one were fixed by changing the Norton settings.


There are a couple of other questions that I didn’t ask but might be relevant if there is to be any workaround.  Are you running any VIs before closing LabVIEW, or just modifying them?  Does this happen on every VI you use, or just on a particular VI?  Is there anything else unusual about the development machine – do you have a different version of Win XP (such as media edition, or tablet)?  Do you have the same problem with other computers?  Would you be allowed to temporarily disable the script blocking in Norton while you work in LabVIEW?


I don’t know what role (if any) NI Serial might have in this, but if you are interested in getting that driver, you can find it here:


Thanks again for the reply, let me know how things go-

Travis M
National Instruments
0 Kudos
Message 4 of 10

It seems to occur whenever I edit a VI and run the VI under the development portion under Labview 8. I ran a small test case (may not be representative). I did the following:

1. ran a VI that use the fieldpoint device (ethernet interface), stopped the vi, and closed Labview. After the VI run, the error is generated.

I am running XP professional. I have no other computer to test it out, as the license only runs on this machine. The run-time versions do not seem to have this problem.

I believe Labview 7 & 7.1 run-time was installed when I loaded NI-Serial-3.0. I need this module for one of the application. I need it for the installation project where I deploy the program. The program uses the serial interface to the Fieldpoint device.

0 Kudos
Message 5 of 10
NI-Serial is needed for the fieldpoint interface. It installed Labview 7.0 & 7.1 run-time on the development machine. I need this module for the additional add-on module for the run-time version on one of my programs. It use the serial interface to Fieldpoint module.
The development machine runs standard XP professional. Since this is license only to one machine, I can not test it on another machine. The run-time version of my program does not seem to have the problem on other computer systems. Disabling the Norton scripting is not feasible, it requires all kinds of corporate approval.
I did the following:
1. Open Labview
2. Open a vi with fieldpoint interface (ethernet)
3. Start the vi
4. Run Vi
5. Stop VI
6. Shutdown Labview
7. Run-time error occurs.
0 Kudos
Message 6 of 10

First of all, I don't believe disabling script blocking for your Norton Antivirus software will affect this, so don't worry about it not being a possiblity. That was more the case when people were using ActiveX controls, which by their nature involve launching scripts with the host application (such as Word or Excel).

I have seen at least one instance of this where a customer had this exact error when shutting down LabVIEW 8. He tried reinstalling LabVIEW, the drivers and the Run-Time Engine, all to no avail. What it came down to, was that one of his LabVIEW 8 VIs wasn't closing a FieldPoint reference when it executed (and I know you're using FP), so could you please doublecheck to make sure that you are properly disposing of all references? This is definitely good programming practice, but I admit it shouldn't cause this level of difficulty if forgotten.
Jarrod S.
National Instruments
0 Kudos
Message 7 of 10

You are missing the point with regard to Norton Anti-virus. Any modification to the Norton antivirus is locked out by the IT people.

As for closing the Fieldpoint, this has to be done by Labview. I am debugging the program and constantly starting and stopping the fieldpoint. These programs are designed to run continuously thus closing the fieldpoint again, is not an option. In fact, I specifically design the front pannel so that the users are not able to stop the program.

0 Kudos
Message 8 of 10
Hi Joseph,

With all respect, my point about the Norton Antivirus software was that it should not be necessary to change it, so don't bother worrying about the fact that you can't. I don't believe it is playing any role in this.

I understand the fact that your FieldPoint applications are intended to run continuously, but you might consider implementing a safe shutdown sequence, even if you only intend to use it while debugging. You do not have to expose this functionality to the end-user. For your sake, however, implement code that closes all the FieldPoint references in you LabVIEW code whenever you shut the system down. It seems quite likely that this is the cause of the R6025 error you are receiving.
Jarrod S.
National Instruments
0 Kudos
Message 9 of 10
That is a good point. But it is not occurring on the run-time version but during the shutdown of Labview 8. In addition, I am pretty sure it was not happening until after the installation of NI-Serial 3.0
0 Kudos
Message 10 of 10