Showing results for 
Search instead for 
Did you mean: 

missing ctrl functions in string edit

I have a string control open for editing.  In program edit mode it accepts CTRL-C for copy etc. fine.  In run mode, CTRL-C becomes just the letter, not the control.  I have used string control with CTRL codes successfully in other projects.  Is there some global command that would cause CTRL keys to be interpreted a plain keys?

0 Kudos
Message 1 of 5


I gave a try to the copy paste its working fine. What is the LabVIEW version you are using.  Can you post the vi in which you are experiencing the problem?

With regards,
(Certified LabVIEW Developer)
Give Kudos for Good Answers, and Mark it a solution if your problem is solved.
0 Kudos
Message 2 of 5

That is the problem -- it works in other vis that I have written.  I am using LabVIEW 8.5.1.


It appears to be something outside of the string function that is causing the failure -- likely something in the menu operations.  I can add a string control outside of the main while loop and get the same bad behavior.  However, if I strip out the menu support, it works.


I have a modified test program to upload but it requires a number of support .txt files.  I tried a winzip but this does not seem to be uploadable and there seems to be a limit of three uploads.  If you can provide a way to upload a dozen or so text files plus the .vi, I can get you a test platform.

0 Kudos
Message 3 of 5



Have you seen this in any other VIs on your system?  What does the VI in question do?  Are you using event structures or anything like that that might be capturing the ctrl key?  Can you create a simple version of this VI that still exhibits the behavior?


Please let us know.




Sam K

Applications Engineer

National Instruments

0 Kudos
Message 4 of 5

Problem appears to be with the Menu.  On entry into the editing code which had the CTRL function problem, I used the "Enable Menu Tracking" function to disable (False) the "Current VI' Menubar" so that attempts by the user to make menu selections while in the editing screen would be ignored.


If this is removed, the string editing function works correctly with CTRL functions etc.

If it is re-enabled, the string editing functions fails to properly receive and/or process CTRL functions.


Is there a problem with my concept of disabling the Menu while editing?

If so, is there another way to prevent the user from accessing the Menu when it is actually not available, i.e. during the edit? 

0 Kudos
Message 5 of 5