Showing results for 
Search instead for 
Did you mean: 


Go to solution

haiii,  my name is Nagendra. i have been trying to use WEB PUBLISHING TOOL.but,while i am doing i could not get and following(sreenshots) commands i am geting. could you tell me how can overcome this problem?.  

Download All
0 Kudos
Message 1 of 7
Accepted by topic author Nagendra.P



First, you should give your message a better title than "labview" because every message in this message board is about  LabVIEW.


One thing I notice is that URL in the address bar of your error screenshot doesn't match the URL that is in the dialog box of your first screenshot.  I don't know if you used the same URL, or if this is the case that the browser changed the address after you typed it in once the page tried to start loading.


Is the error screen shot from the same PC as the one the VI is running on?  Or a different one?


The error says "connection refused".  I wonder if the firewall is blocking that port, even more so if you are trying from a different PC.  If that is the case, try it from the browser on the same PC first to see if that works.


It looks like you are using Chrome.  That is my least favorite browser.  Try using a different browser such as Internet Explorer.  I think the code that runs on the browser to make the remote web panels work only works on some browsers and not others.  If I recall, older IE was fine.  The new "Edge" browser that Microsoft is making obsolete faster than the older Internet Explorer, I think can't do web panels.  I can't remember if Chrome or Firefox were browsers that worked, or didn't work.



0 Kudos
Message 2 of 7
Accepted by topic author Nagendra.P

yes brother, i am using chrome & firefox. now onwards i will use internet explorer.

i ran program & browsed URL in same PC. 

I could get snapshot and monitor viewing modes,but i could not get embedded mode in web publishing tool.i am getting embedded mode as i mentioned below.

can u please tell me how can i get.

0 Kudos
Message 3 of 7

some time iam getting embedded mode as below

0 Kudos
Message 4 of 7

You see in that last screen shot it is talking about a blocked plugin.  Did you follow those instructions on screen and see what that link has to say?


0 Kudos
Message 5 of 7
Accepted by topic author Nagendra.P

Most modern browsers no longer support NPAPI plugins for security reasons, so this will not work.



0 Kudos
Message 6 of 7

Thank you brother, 

i installed internet explorer and now, i am getting embedded mode on web page. But, i could able to get on my laptop only. i could not getting VI front panel control on another laptop by entering same URL in web page. while i am trying i am getting a page as attached below. could you tell me how to get  VI front panel control web page on another laptop or system?

0 Kudos
Message 7 of 7