LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

fpga

Receiving FPGA Compile Error:

 

"The compilation cannot be performed by the compile worker. The compile worker may be configured incorrectly for this compilation, or it may be in an error state."

 

We installed LabVIEW 2013 using the NI Developer Suite 2014 including the LabVIEW FPGA Module Xilinx Tools and the Drivers on our NI PXIe 1071 chassis with 8135 controller using Windows 7.

 

Using: FlexRIO 7965 R

When we installed the software orginally the FlexRIO was not yet installed. Then after installing the drivers we installed the FlexRIO. However, since then, we have reinstalled the software while leaving the FlexRIO installed.

Could this have something to do with NI not finding the compilation tools?

See screen shot..

Thank you for any help with this matter.

 

-Josh

0 Kudos
Message 1 of 11
(3,991 Views)

Hello Josh. 

 

For what I can see on the scrennshot you attached, you are getting an NI-Farm Error. This happens when the version of Xilinx Tools you have is not the proper one, or when it is corrupt. I believe this documents might  help you with your problem.

 

NI-Farm Error -123002 or -123011 When Compiling LabVIEW FPGA Code
http://digital.ni.com/public.nsf/allkb/2C6ED1D20C9FF80D8625779D00675A2E?OpenDocument

 

Which Version of the Xilinx Compile Tools Do I Need to Compile My LabVIEW FPGA Code?
http://digital.ni.com/public.nsf/allkb/a4b20d58c051dfb386257a56007bb0b2?OpenDocument

 

 

Fabián M.
Internal Sales Engineer
National Instruments
0 Kudos
Message 2 of 11
(3,949 Views)

Hi JoshThompson!

 

Thanks for your post. We are aware of an issue with the compile tools installed from the 2014 developer suite (2013 sp1) where the compile worker is installed with missing dependencies. We are taking immediate action to push out a fix for this and you will receive a notification through NI update service when the fix is available.

 

In the meantime, our recommendation is to downgrade to the 2013 installation of the Xilinx tools. No fixes were made between 2013 and 2013 sp1 in the compile worker or in the Xilinx tools so no worries there.

 

Go to Control Panel >> Programs and Features and select National Instruments Software. 

 

This will launch a window where you have the option to select various NI software products and modify/repair/remove them.

 

Select NI LabVIEW FPGA Xilinx 14.4 Tools and select Remove.

 

After the software has been un-installed, go to the NI LabVIEW 2013 FPGA Module Xilinx Tools 14.4 donwloads page and install this version of the tools (released with 2013) or you may install the tools from your original LabVIEW 2013 developer suite disks.

 

Please post back or call support if you have any problems with this process, we want to make sure you are up and running until we push out a fix.

0 Kudos
Message 3 of 11
(3,937 Views)

Hello all,

 

I'm using a Windows XP machine and I have the same problem since one week. The suggested way to work with the "old" Compile tools 14.4 doesn't work.

Does anyone has another idea.

 

Thanks for help

0 Kudos
Message 4 of 11
(3,897 Views)

After upgrading to LabView 2013 SP1 32-bit (from 2011SP1) I haven't been able to compile my .vi's for the Virtex-5 FPGA in the Flex Rio NI PXIe-7953R module anymore. I am running Windows 7 64 bit.

 

I get the same results as the other users mentions above, and trying to manually start the Compile Worker seems to do nothing, ie no window popping up, not even a notificatino icon on the sytem tray. However, it creates a lock file in C:\Program Files (x86)\National Instruments\FPGA\CompileWorker called ".NI.LV.FPGA.2013.CompileWorker.lock"

 

I've tried uninstalling the Xilinx 14.4 package, and reinstalling the FPGA module from the previous DS 2013 version as suggested, without help.

Now I've uninstalled Xilinx 14.4 again, and will try to install "2013Xilinx14.iso" after downloading it.

 

I tried (out of curiosity) to manually launch the "FPGACompileFarmConfiguration.exe" residing in the same folder as the compileworker, and it crashed immediately,

0 Kudos
Message 5 of 11
(3,878 Views)

Problem solved, after upgrading Microsoft .NET framework to version 4.5(1).

 

0 Kudos
Message 6 of 11
(3,859 Views)

Hello,

 

an update to .NET Framework to version 4.5 is not possible for all Windows XP users. Is there a solution for us or do we have to downgrade to original LabVIEW Version 2013?

 

The suggested way with downgrading only Xilinx Tools doesn't work at all in my case!


I would be very glad to get an answer what I can do to make working possible after more than one week of installations.

 

Thanks a lot.

 

Regards

0 Kudos
Message 7 of 11
(3,837 Views)

Hello dfschunk

 

I know the process can be a little bit frustrating, but hopefully we will get it up and running soon. Which version of the FPGA Module are you using? I am supposing that it is the 2013 SP1. Can you try downgrading that to the 13.0.0?

 

Regards 

Fabián M.
Internal Sales Engineer
National Instruments
0 Kudos
Message 8 of 11
(3,817 Views)

Hello FmTesla,

 

I made just the thing you suggested -> Downgrade to LabVIEW2013. At the moment the FPGA.vi compiles an I think everything will work fine again.

 

I would be glad if you can solve the problem. If not I wait with updates until getting a computer with Windows 7.

 

Thanks and regards

 

dfschunk 

0 Kudos
Message 9 of 11
(3,810 Views)

dfschunk. 

 

You downgraded LabVIEW or just the FPGA module? If you downgraded LabVIEW, have you tried downgrading just the FPGA module? 

Fabián M.
Internal Sales Engineer
National Instruments
0 Kudos
Message 10 of 11
(3,790 Views)