Showing results for 
Search instead for 
Did you mean: 

fpga is busy

fpga is busy

I am getting this error when i am trying to open a fpga vi reference. I am also not able to run the vi or do anything.


Error -61141 occurred at Open FPGA VI Reference in>

Possible reason(s):

LabVIEW FPGA:  Operation could not be performed because the FPGA is busy.  Stop all the activities on the FPGA before requesting this operation.

FPGA activities:

Reference open through FPGA interface.


Any help??



0 Kudos
Message 1 of 7

Re: fpga is busy

Are you getting this error on the PC (78xx)or a cRIO? Does this error always come or only after running a couple of times. Are you repeatedly opening and closing references?



0 Kudos
Message 2 of 7

Re: fpga is busy

After opening the reference, use a reset method before running. It seems to
be running already, which happens e.g. when the fpga has a continuously
running loop.



0 Kudos
Message 3 of 7

Re: fpga is busy

If you get this error, set your chassis to FPGA mode in the properties and then redeploy the chassis. You should not have to recompile your code.

Message Edited by mishkin on 04-14-2009 12:20 PM
0 Kudos
Message 4 of 7

Re: fpga is busy

Hi I have this error as well. What does it mean to redeploy the chassis. Whats the chassis? 




0 Kudos
Message 5 of 7

Re: fpga is busy

I'm using cRIO-9114 and I also have this problem. I think it originated as I had endless loops inside the FPGA and tried to start a FPGA reference but the program crashed. So the reference never got closed and now what ever I do related to the FPGA returns the error that "FPGA is busy".


Trying to add C module, viewing RIO Device Setup or deploying binaries on the chassis return the error.


I didn't find any way of getting rid of the old program running on the FPGA.

0 Kudos
Message 6 of 7

Re: fpga is busy

I solved my problem by formatting and reinstalling the system through MAX.

0 Kudos
Message 7 of 7