LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

error code 2147287038

I'm using some database subVIs in a LLB developed in LV 7.1 PDS.
I wanted to test the application on another computer where I have LV 7.1 FDS without Database Connectivity Toolset.
I saved all the hierarchy in a LLB, including the database subVIs.
When I'm opening and running the main VI in LV 7.1 FDS, I'm obtaining an error code -2147287038 occured at DB Tools Open Connec (String).vi.
Is this because I don't have Database Toolset installed on the second computer or because LV 7.1 FDS does not allow polymorphic VIs (DB Tools Open Connection.vi is a polymorphic one).
Tom
0 Kudos
Message 1 of 3
(3,564 Views)

Hello Tom,

 

All versions of LabVIEW should be able to handle the polymorphic VIs.  I do not belive the problem is with this.  I would start off by checking into making sure that the database on both computers is the same, and the database software is installed in the same way, etc…

 

As far as the software installation of the Database toolkit, it is against the license policy for that version of LabVIEW and the toolkit to have it installed on multiple computers (LabVIEW 8 and LabVIEW 8 toolkits have changed this slightly, but the agreement for LabVIEW 7.1 and prior remains in effect).  If the user of the other computer is licensed for LabVIEW and the database toolkit and you wish to test the software on the other computer, I would recommend actually running the database toolkit installer program to ensure that the installation goes correctly.

 

Hopefully this helps – good luck, and let us know if you have other questions!

Travis M
LabVIEW R&D
National Instruments
0 Kudos
Message 2 of 3
(3,554 Views)

Dear Travis,
Thank you very much for your answer.
I modified the library by replacing the polymorphic VIs with normal VIs and is working fine. It's not the first time when I encounter the same problem and each time I solved it by replacing the polymorphic VIs.
Regarding the license: yes, the second computer is also licensed for the database toolkit but I was not so sure that I didn't modified any subVI while developing the application so I just wanted to be sure that I will use exactly the same hierarchy.
Thanks again,
Tom

0 Kudos
Message 3 of 3
(3,548 Views)