Showing results for 
Search instead for 
Did you mean: 

error 200279

Greetings All,

I am having the same error occur. However, my application requires a somewhat faster rate. I'll attach my LabVIEW program, but here's a general description:

- Inside a while loop, I have a master state machine that goes through Initialize, Instrument Setup, and Runtime states.

- In the Runtime state, specific process data is displayed on the front panel. I want the refresh rate to be bound by the speed of the computer (i.e. as fast as possible). I setup a "loop time" counter to determine essentially how fast the program runs, which is usually 0-1 ms.

- Also in the runtime state, there is an "Acquire Data" control to another loop that writes data only at when a certain amount of time has passed for a predetermined "acquire rate"

I'm running into this issue using a SCXI-1000 - SCXI-1102 - SCXI-1303 setup to collect thermocouple and voltage data. Here's the big kicker:

Everything works absolutely fine as long as I stay within LabVIEW once the program is running. When I open another program such as a required 3rd party IR camera software package or Excel, the error 200279 pops up.

I never had this issue using cFP systems, but the TC modules are too slow.

Ideally, the SCXI should be setup for 1 sample/channel such that the computer requests a sample when its ready to read, but I am quite uncertain how to do that.

Anyone who opens the VI, sorry for some spaghetti; it's always messy anytime new hardware is brought in.

0 Kudos
Message 11 of 14



Did you look at the thread?  What version of Labview are you running and OS?




0 Kudos
Message 12 of 14


I have read all the posts in the thread. The reason I'm still posting is because I have tried the LabVIEW code on one of the replies - this thread seemed to be most relevant to my situation; however, the SCXI-1000 runs far too slow in the state machine. The one post where they outline how to setup in MAX was the first thing I tried - once again it appeared the hardware dictated the speed when I'd like the computer (the LabVIEW program) to set the pace. But if I tell the SCXI to run at near the maximum rate (via the "Timing" function) and also set my buffer (using the "Continuous Samples" option) to be about 100000, the error still occurs when I open an outside program. I can have the LabVIEW program running forever, and I can even write my data, but opening an outside program causes the error. Something like this means that the computer and the SCXI need to be even more in sync such that the few milliseconds it takes to open and operate the 3rd party software does not cause LabVIEW to drop a sample and give me this error. My version of LabVIEW is 8.5 on Windows XP (sp3).


0 Kudos
Message 13 of 14

Hello JamesW3157,


This is Andrew Brown, an Applications Engineer from National Instruments. As I understand your issue, LabVIEW is normally able to use a very large buffer to handle the samples you are reading in at maximum speed. This buffer is on your computer's RAM, which is of finite size. Thus, when you open up an external program that needs space on your RAM, the buffer either is reduced in size or overwritten by the other program. In either case, the error -200279 would be the result.


A good article covering this topic is Why Do I Get Error -200279 from my DAQmx Read VI or Property Node. Thus, possible solutions for this issue include reducing sampling speed and increasing the RAM on your computer.


Please let me know if you have additional related questions. Thanks, and have a great day!




Andrew Brown



Software Engineer
National Instruments
0 Kudos
Message 14 of 14