LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

[bug] LV opens extra VI

Solved!
Go to solution

This must be a bug, and it's annoying, though not critical. In my current project, when i open the main.vi, it also opens setup.vi. Every time. Why!? In other projects it doesn't, but for some reason LV finds it logical to open 2 VI's when i order 1.

Opening setup doesn't open main, ofcourse.

 

Any way to fix this behaviour?

 

LV2011

 

/Y

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 1 of 4
(2,971 Views)
Solution
Accepted by topic author Yamaeda

Is setup.vi called from Main?

 

I can imagine that the call is configured for "Open front panel when loaded" (SubVI Node Setup).....

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 4
(2,969 Views)

Hah! I found it! The VI had "Show front panel when loaded", which is what happens when i open the main.vi ...

 

No bug!

 

/Y

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 3 of 4
(2,967 Views)

You answered as i found it out myself. Thanks. 🙂

/Y

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 4 of 4
(2,966 Views)