LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

**bleep** you, error 1502!!! (shakes fist)

So, I have had this problem before and I believe that last time it mysteriously resolved itself (probably because I was in the middle of development and whatever magical changes I made caused the problem to go away), but now I can't shake this terrible problem again and I am in a bit of a crunch.

 

I am attempting to build an executable for an RT machine (PXI), and, after having recently successfully built this application, have apparently made some sort of change that has made the linker puke with the error 1502.  The explanation of the error goes something like "yada yada AB_something or other... LabVIEW:  Cannot save a bad VI without its block diagram."  Now the VI in question is one that is associated with an LV Class and is called Configure.vi (probably not relevant to anything, but it seems not to be associated with an LV built in libraries).  I have successfully built an executable with this VI as the main VI, but when the VI in question is called in a larger program, the linking process just seems to die when there is an attempt to save this VI in the linking process.  Does anybody have any thoughts regarding this?  Does prayer help?  I have looked around at a couple of post and there is remarkably nothing helpful regarding the resolution of this error.  So, any thoughts might be of value.

 

Peace, Matt

0 Kudos
Message 1 of 47
(5,053 Views)

I wish I could help you. I also had that happen to me. It was a long time ago and I was shooting in the dark trying to fix it and I don't know just how I finally did fix it - I tried many things. But I think what I did was moved my problem vi out of the project, saved the project, exited LabVIEW, opened the problem.vi and saved it, then put it back into the project. I did a mass compile somewhere in there.

 

Edit: Oh yea I also did a bunch of cursing.

=====================
LabVIEW 2012


0 Kudos
Message 2 of 47
(5,030 Views)

Thanks, Steve.  The weird thing about the error is you never see any NI rep coming up with a conclusion in any of the forums.  It's like everyone just gives up and wanders away.

 

And regarding the cursing - the edit on my title makes the initial title seem worse than it was - let's just say that the bleep was something that started with d and is used to contain a large body of fresh water.  Who would have thought the NI forums could be so prudish Smiley Tongue.

0 Kudos
Message 3 of 47
(5,005 Views)

I actually didn't try the forums for that one. Did you get it fixed?

=====================
LabVIEW 2012


0 Kudos
Message 4 of 47
(5,000 Views)

Well, I thought I would try the old Windows trick of a complete reboot - and when I did this some funniness happened so now I am trying to recover from that.  But, I am going to try to get everything up and moving again, do a dance and then see if I can build this exe.  I will let you know.

 

Matt

0 Kudos
Message 5 of 47
(4,991 Views)

Maybe your hard drive is going south.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 47
(4,951 Views)

So....

 

This controller is located in a chassis that is used to control two different instruments that run in the same main VI but on separate loops.  I had one of the loops disabled using a diagram disable structure (when I had built the executable before, that structure was not there) in order to remove one of the instruments from the operation.  In an act of desperation I actually removed this structure (and all of the underlying code) and - voila - I was able to build the executable.  Ultimately that code has to be folded back in, but for now this will do.  I find this all a little disconcerting given that the VI that the build was complaining about turned out to not really be a problem.  Are there any NI folk that can comment on this? 

 

And bilko, I just replaced the hard drive with a new SSD so I certainly hope that is not the case 😮 ; but who knows, I will keep an eye out for that.

 

Peace, Matt

0 Kudos
Message 7 of 47
(4,935 Views)

Hi Matt,

 

We (those at NI) don't mean to fall silent on this issue. The truth of the matter is that R&D is aware of this error, and given that we use a fair amount of LabVIEW ourselves, it's an issue that is a problem for the large base of internal users as well who are building executables. As a result, this error is a very high priority for R&D. The reason there is so much silence on this issue is because we're still trying to figure out exactly what causes this error. We're still tyring to pinpoint this error and determining how to make a fix. I do apologize for the trouble that you are having with this issue, but I do want to confirm that this is an error that we are aggressively trying to tackle. Please bear with us as we work to develop a solution.

Sanjay C.
Embedded Software Product Manager| National Instruments
Message 8 of 47
(4,683 Views)

I'm bitten by this error too. Smiley Sad. This is a large project that takes minutes to compile, so finding what can trigger the error takes hours.

 

I have looked at other posts talking about the error, and it's a big mess, between potential name conflicts, constants wired to case structure, disconnect typedefs in build settings. Please NI if you don't have the patch yet, provide us a way to debug it, and tips to remove the error. We're already late on the project and completely blocked by this.

 

HELP

0 Kudos
Message 9 of 47
(4,598 Views)

I seem to have been bitten by this ERROR as well.  Has anyone come up with a solution yet?  I've tried changing the Build settings & removing Disable DIagram Structures from my code but nothing seems to help.  Unfortunately it takes about 45min each time I try a build so it could easily take a number of days to get a result at this rate.

 

 

0 Kudos
Message 10 of 47
(4,536 Views)