LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

arduino uno error 5002

Solved!
Go to solution

hey,

i am using labview 2011,lifa 2.2.079, arduino uno rev3 connected via usb to the pc

 

if i open the device manager i find under ports: arduino uno (com3)

also if i open ni max,in the devices and interfaces under serial and parallel i find com3 when i click on it i find in the device status box:this device is working properly


 i checked also my arduino board by using the arduino software ,i tried to upload the blink example and it works so it is not a hardware problem

 

but when i am trying to build any vi( i tried the one that turn on and off the led at pin 13)  or using any example existing in the lifa for example the analogue reader vi i get the 5002 error and nothing works..

i checked the baud rate and i tried to increase the timeouts and i created a constant for VISA resource to choose com3 in the init.vi (all of these are solutions found in other discussions here in the forum) and nothing worked i am still getting the error

can anybody help me in this?

thanks a lot

0 Kudos
Message 1 of 4
(5,317 Views)
Solution
Accepted by topic author thespecialone

download the arduino software 1.0.5.then enter the software click on file>open...>hard disk cSmiley Sadfor example)>program files>national instruments>labview>vi.lib>labview interface for arduino>firmware>lifa_base>lifa_base. then upload the file on your chip , close the software , enter labview and launch your vi it should work. if you didn't understand you can follow the steps mentioned in a youtube video..enter youtube.com >labview arduino..watch the first video that appears.

0 Kudos
Message 2 of 4
(5,296 Views)

DID YOU FIX THE PROPLEM ?

0 Kudos
Message 3 of 4
(4,879 Views)

Change the baud rate defined in the LabVIEWinterface.h arduino header file (in LIFA firmware) to 9600.

#define DEFAULTBAUDRATE 115200

to

#define DEFAULTBAUDRATE 9600

Cross check your active com port and board chosen. Run the model. Good Luck.

0 Kudos
Message 4 of 4
(4,018 Views)