LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

application installer issues

Totally bamboozled here. My installer project that has been working for a couple of years, and only stopped when I accidently saved the vis as 2011 from 2010 is driving me crazy! I think I have identified what the issue is but I cant resolve it. When I take the application exe to application installer you can see the structure within the “project files view” that should be recreated within “destination view” for some reason its started adding the entire path to my sub dirs from my works server to this view , so when it installs to my c drive, my program cant fetch certain files because they are buried in superfluous folders!

 

As an example, the wecel template is contained within the reports folder and should look like this

C:\Program Files (x86)\Company PVT\Reports\Company PVT Report.xlt

What it actually installs like is

C:\Program Files (x86)\Company PVT\Reports\J\Projects\75) Fluid Sampling Analysis - Phase 2\15) Source Code\builds\PVT\Company PVT\Reports\Company PVT Report.xlt

Why has it suddenly stated doing this? In that same source files view, I tried using the left arrow to remove the three folders from destination view and then tried pushing them back in by highlighting them in project files view, but the right arrow is greyed out. It wont let me shift the entire folder only the files contain within.

Any help much appreciated.

0 Kudos
Message 1 of 2
(2,247 Views)

What it really means is that your main VI has loaded the sub VI's and dependencies from a folder previously used for building the application.

 

I would suggest Save As entire project to different location and change the folder structure with the project explorer and create new executable.

 

Best regards,

Vijay.

0 Kudos
Message 2 of 2
(2,208 Views)