Showing results for 
Search instead for 
Did you mean: 

Web Publishing Tool wont display my program in other computers

Go to solution



i want to ask about three points in this post:


-I am using the Web Publishing tool to post my program on a website. The LabVIEW server is working fine and the website is posted online and it works fine; however, when i check the website in the host computer the program displays fine and t works perfectly, but when i check the website in any other computer the program wont load at all. I thought that maybe i didnt have the proper plug-in in the other computer, so i downloaded it and it would still not work. I tried this in 3 different computers and the program would not load on the website. Any ideas?


-Also i noticed that in order for me to open the website i have to write the entire url (, the labview server will not go automatically to the index page by just typing "" is there anything i can do there?  


-Since this program is for a research project, the webpage where the program is located can only be reached and used by certain people. I tried using PHP to create a log-in page but LabVIEW server does not support it. Is there any way I could approach the security issue for this program without denying the control of it?



Thank you for your help.




0 Kudos
Message 1 of 26
Do you have the LabVIEW runtime on the other computers? This is a requirement.
0 Kudos
Message 2 of 26
Yes that is the first thing i download before opening the website. One of the computers that i have tried it in has labview installed in it.
0 Kudos
Message 3 of 26
Perhaps some ports are blocked.
0 Kudos
Message 4 of 26

port 80 is standard for web use in most computers if not all and i made sure that port was enabled. Also labview server is running in that port so there should not be any problem connecting to other computers.


thanks for your help

0 Kudos
Message 5 of 26

With regard to question #1: Check the Web Server options of the VI you're publishing. From the VI, go to Tools>>Options>>Web Server. Check that you're enabling Browser Access for the computers you want to be able to view the published VI.


With regard to question #3: You can use the same Browser access list to enable viewing and controlling, viewing only, or no access for specific IP address.


As for #2: What URL do you see on the "Save the New Web Page" page of the Web Publishing Tool wizard? If you give the page a name here, it shouldn't default to "index.html", but I do believe that you'll need to name it something.

Product Support Engineer
National Instruments
Message 6 of 26

Thank you for replying to my message.


I checked the Browser Access and i added one of the computers that will be using the website and nothing changed. I am still not able to see the program; the only thing i see is "Downloading 0% of 0 bytes".


For the URL i have . I have used other servers before and i dont have to write the whole path in order to get to the page, if i write it should take me to the home page or index.html, instead it says "Oops. This link appears to be broken.", so in order to make it show up in the browser i have to write the entire path.


Any ideas?




0 Kudos
Message 7 of 26

im still not able to get the page running does anyone have any ideas what the problem could be? 



0 Kudos
Message 8 of 26



Your page is actually working for my computer. I went to the html page you linked, and I can see the VI and even obtain control of it. It appears that your web server is set up correctly, so the error must be occurring with the client computers.


You mentioned that the client computers have the LabVIEW Run-Time Engine, but is it the same version as the server computer? This is required.


Can the client computers ping the server computer? If not, there's likely a networking issue preventing the page from loading.

Product Support Engineer
National Instruments
Message 9 of 26
Accepted by topic author Gant88

Thank you LaRisa,


it is good to know that you obtained control of the program because that is an issue that i need to fix.

I found that the problem was enabling the vi in the server. That is why you were able to see it. About two hours ago i was able to see the program in another windows. Thank you.


Do you know of a way to enable the control to certain users? 

0 Kudos
Message 10 of 26